Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Kevin Jackson

Clutches slipping

Recommended Posts

I have a 98 bayou 300 2X4 . I had no issues and then pressure washed it and next time I got on it the clutch was slipping bad at high rpm’s. Oil level is good. Is it likely that it could be fine when parked and then immediately start slipping next time I jumped on it for it to be a worn clutch? Could water have gotten in somehow? I don’t have any noticeable leaks. 

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By MarkinAR
      About done with the Kodiak finally. Oldest took it out today and ran the piss out of it, buried it to the belly, and I think its finally about ready to trust. However, there is a clutch slipping that needs to be addressed. It pulls fine from a dead stop to about half throttle. If you go ahead and open it up, the clutch basically lets go at higher RPM. My question then is; centrifugal clutch or main clutch pack bad? I assume since it pulls at low RPM then it's the main clutch pack slipping at WOT. School me though: where does the centrifugal clutch end and main clutch pack begin?  Also added to this issue, he was crusing down a gravel road and all 4 wheels locked up and it died. I assume it tried to throw 2 gears at the same time and locked up. It unlocked though and shifted ok after coming to a stop. 
    • By JCH
      Hi there
      I am in need of a manual for my KLF 300 Bayou 4x2 . I've found others on here for the 4x4 model, but was wondering if I need a separate 4x2 manual. Does anyone know?
    • By dbconn55
      Hi guys I have a 2003 Arctic 250 4X4 it starts idles and runs great for about 10 min. then it spits and sputters and dies but it starts right up like nothing happened idles good till you give gas and it does it again let off the gas and it's idling great again this goes on for about 15 to 20 min. and then it takes off runs good all day like nothing was wrong.
      I cleaned the carburetor it looked like a new one inside found a little gunk in one orifice, new air filter no crimped lines air line to tank good I did put a meter on the battery idling it said 16.5 V that's high I think would a voltage regulator cause this?
      Suzuki shop wanted to sale me a stator for $556.00 but said it could be something else also thought I'd see what you guys say about it
      Thanks
    • By Squirrel
      Several months ago, I finally got around to fixing the bayou. Rebuilt the carb, replaced the fuel selector switch, hoses and fuel filter, and she ran great. Only had 2 minor issues since then where, at higher speeds, it acted like it was choking out when I let off the throttle.
      Lately I've noticed if I let it go for more than a week, it almost drains the battery dead trying to start. I initially thought battery, but after inspecting I found very little if not any fuel flow through the line until it starts and runs.
      I'm a little baffled and don't have much time to mess with it as most my free time right now is spent on getting my rv up and ready for hunting season in the next 3 weeks. So any help on quick diagnosis checks would be helpful. Otherwise I'll just keep starting it every 3-4 days to keep things primed until I'm done hunting.
       
      Oh, and another question on a different topic. Does anybody know what the mounting brackets on the front rack are for? I'm referring to the 2 angled metal tabs with threaded holes that are located on the left, near your knee when sitting on the quad?
       
      Sent from my SM-G950U using Tapatalk
       
       
    • By Ben Lennon
      Hi guys new to this forum and thought I’d jump on as I’ve just bought my first quad a Kawasaki bayou klf300c 89 model. It had starting issues when I bought it so I’ve gone thru and replaced the cdi, voltage regulator and starter solenoid aswell as rebuilt the starter motor after all this it was still free spinning on electric start so I pulled the stator cover off to find the fly wheel wasn’t spinning so replaced the one way clutch bearing put it all back together and still not engaging at all. I’m at a loss and looking for some ideas on we’re to look next to solve the problem
      cheers Ben 👍
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...