Quantcast
Jump to content

  • Do you own an ATV, UTV or SxS? Join our Community Forum!

    QUADCRAZY ATV Community and Forum are FREE to join! We keep our ATV, UTV, and SxS forums clean and user friendly. All first time posters in our forums will have to wait to have their content reviewed and approved. Once your first ten posts are approved, you will no longer need to go through a forum post approval process. To bypass the approval process with immediate access and a NO ADS experience in our ATV, SxS, and UTV forums, consider subsribing to a Premium Membership

Protect Your Look


Recommended Posts

  • 4 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Forum Topics

    • By p5200
      The studs in the sprocket hub are stripped out. The hub is probably walloed out also. Probably will have to have a new sprocket hub. I doubt I have the ability nor the tools needed for this job. Thanks for all suggestions/opinions! 

      20240225_155255.mp4   20240225_155255.mp4 20240225_155255.mp4 20240225_155255.mp4  
    • By olddude
      Just wondering where you guy's an Gal's get your parts. I love buying OEM stuff but sometimes they just cost to darn much for what they are. I know, I know everybody needs to make a living but dang! $ 97.00 for brake pads on one side of the front of my KingQuad. There has got to be a better way.
    • By Nadamamasboy
      I have an '88 250 that's going to need some repairs. Are parts still available for these older machines? Thanks in advance 
    • By jashadams
      Hey all back again with my 1989 moto 4 250.
      After putting a new carb on it it's really sputtery, it has new gas and I'm wondering what to tune on the carb to make it idle better. I've attached a video to describe the issue more. The bike is still work in progress but I think the video gets the point across. Thanks!
      Snapchat-1142015191.mp4
    • By p5200
      Hello folks, my machine wound up with I think water in the tank etc. It runs but speeds up and slows back down randomly. When not running I don't see gas dripping  from the drain nipple on bottom of float bowl and drain screw is closed tight. With normal idle speed I see no leaking. When the idle speed increases quite a bit on it's own, gas appears to start slowly dripping from float bowl drain nipple? I'm wondering if the carb is flooding and the gas is actually coming from higher up and just appears, to be coming out of nipple but, is actually running down the sides of the nipple? I put a kit in the factory Mikuni carb last year after sitting for a while and I think the gas in the jug I used had drawn moisture. I plan to pull the carb tomorrow and clean everything out. I was just curious if anyone else thinks it's probably something in the carb and is, acutally a flooding problem? Thanks Folks! 🙂
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...