Quantcast
Jump to content

donerightautomotive84

Members
  • Content Count

    4
  • Joined

  • Last visited

Community Reputation

0 Neutral

About donerightautomotive84

  • Rank
    Forum Beginner

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Ok f Cleaned the carb oyt didnt really find anything concerning reassembled it no change. Choke doesnt change the lebgth of time it runs. Am i missing somekind of sensor or switch that could be causing this. Sent from my LM-Q720 using Tapatalk
  2. I dont think its timing related as i can pull start the motor im leaning more towards my carb screwing up maybe due to bad fuel lines. (All are new now) though i may be wrong Sent from my LM-Q720 using Tapatalk
  3. I do have an inline spark tester and will check that out this weekend as its currently pulled apart again i went ahead and prdered a fuel valve (old one had just started leaking right after i originally posted) and another fuel pump both will be here friday abd my buddy has a brand new caltric carb im going to put on it at the same time so hopefully i can rule the fuel system out all together. Im also cleaning my tank and the pickups in it at same time hopefully all works after. Ive tested the etc and its working right so im pretty sure its not the problem. Sent from my LM-Q720 using Tapatalk
  4. Ok so 2000 sportsman new.caltric carb new fuel pump new jug and piston new cdi and coil finally get to start it and itll idep for 5 to 10 seconds and die what am i missing people any help id love ya forever lol Sent from my LM-Q720 using Tapatalk

×
×
  • Create New...