Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Casey Martz

07 Kingquad 450

Recommended Posts



Not familiar with the KQ 450 unit, but on my KQ 700 there are topics about the Throttle Position Sensor (TPS).  not sure if it applies to your bike though.  They talk about jumpering pins on the diagnostic port to display on the LCD the position sensor being either above or below or on target.  Something I still need to check on mine so haven't been through it myself though.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By BuckBilly
      I like to ride in wooded and grassy areas. It takes my mind off the everyday routines and helps me deal with my father's cancer. Also gives me a reason to get involved with forums like this one.
    • By cgilley
      Ran it out of gas last month... Works fine for 3 or so days then refuses to start.... Changed out the sparkplug and it will run for 15 or so seconds before shutting off.... Cleaned out the fuel system and injector and it misses when idling as well as shutting off at idle every so often... It is giving me no other issues and sounds and runs fine while riding... Only issue is cutting off at idle.....
      Ideas anyone??
    • By JacobSlabach
      hey so never ran into this before but i recently got a 04 honda rubicon 500.  bought it from my doctor not running and the front brakes were locked up.   cleaned the carb and it fired right up and runs great.  these model atvs have drum brakes front and rear.  not a fan.  lost all brakes on this one when i hit some water and it got inside the rear drum case.  so i ordered new shoes for the rear end no biggie.  front is more complicated.  has hydraulic drum brakes not sure who thought that was a good idea but the pistons in the drums rusted and locked up from it sitting with moisture in the drums.
      so i had a choice to make- 1. buy new brake pistons ($120 for a set of 4) or 2. order super atv's disc brake conversion kit for $250.  i HATE drum brakes so i went with the conversion kit.  it said it was easy to install with no specialty tools.  so i order it and turns out i have to press the studs out of my hubs to get the disc on.
      anyone ever done this and if so how?
    • By stuman6669
      my buddys 02? warrior cuts out as soon as you give it throttle. it stays running, but it missfires and pops through the exhaust. it returns to idle and idles fine. the timing looks ok and we have swapped the carb with no change.its been sitting a while waiting on carrier rebuild, it ran fine before that. any ideas?
    • By Bryson Bailey
      Hey I have a Kawasaki buyou I put a new carburetor on it and a brand new spark plug coil and still firing up could you know what my problem is anyone please
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...