Quantcast
Jump to content

  • Do you own an ATV, UTV or SxS? Join our Community Forum!

    QUADCRAZY ATV Community and Forum are FREE to join! We keep our ATV, UTV, and SxS forums clean and user friendly. All first time posters in our forums will have to wait to have their content reviewed and approved. Once your first ten posts are approved, you will no longer need to go through a forum post approval process. To bypass the approval process with immediate access and a NO ADS experience in our ATV, SxS, and UTV forums, consider subsribing to a Premium Membership

Studs


Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Forum Topics

    • By p5200
      I'm having trouble identifying Mark. I know where the mark is in the Stator cover. Is the T at about, the 12 o'clock position in this photo? I've got to buy another Stator cover as the one I have has a hole at the bottom of it. Due to failing eyes, I have a lot of trouble anymore. Thanks! 🙂

    • By p5200
      Can someone please tell me what size socket I need to remove the valve cover? Thanks! 🙂
    • By p5200
      I added more fresh gas it sat one day now, it's acting up again. Before cleaning out carburetor it wouldn't idle good and had gas leaks from carburetor. Now it idles pretty good but, if I increase throttle speed at a certain amount it starts missing bad. I'm going to try and post a short video. Just about ready to give up on this thing.😒  you can see reflection perking in video.

      20240217_114429.mp4
    • By p5200
      Hello folks, my machine wound up with I think water in the tank etc. It runs but speeds up and slows back down randomly. When not running I don't see gas dripping  from the drain nipple on bottom of float bowl and drain screw is closed tight. With normal idle speed I see no leaking. When the idle speed increases quite a bit on it's own, gas appears to start slowly dripping from float bowl drain nipple? I'm wondering if the carb is flooding and the gas is actually coming from higher up and just appears, to be coming out of nipple but, is actually running down the sides of the nipple? I put a kit in the factory Mikuni carb last year after sitting for a while and I think the gas in the jug I used had drawn moisture. I plan to pull the carb tomorrow and clean everything out. I was just curious if anyone else thinks it's probably something in the carb and is, acutally a flooding problem? Thanks Folks! 🙂
    • By p5200
      Does the pull rope have to be on the machine to get top dead TDC? The rope was gone on this one when I got it. Or, can a plastic tool be used in spark plug hole to feel for TDC on compression stroke? Thanks for all info! 🙂
  • Similar Tagged Forum Content

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...