Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Jordan Ritzman

Performance parts on 2 strokes

Recommended Posts


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By JJ78
      I have a yamaha big bear 400, tested all fuses and relays. When I turn on key I get nothing, no neutral light or headlights. Could it be the key switch bad?
       
    • By jwline
      Friday evening went riding, rode for a good hour or so everything was fine. I went to take a short ride to the restroom (less than 100 yds away) and all of the sudden everything flickered and then just died out. Accompanying the problem I noticed the killswitch completely locked up. Once daylight hit took the killswitch apart to find it had shorted out and melted the plastic inside. Has anyone else had anything similar to this and if so what did you do to fix the situation? I have a new killswitch on the way to replace the obvious problem but was wondering could there be a bigger issue at hand. We tested with a voltage meter to make sure everything was still getting power from the battery and as far as we could tell it was.
      Any advice/info would be GREATLY appreciated.
      Thanks.
    • By mkibbe
      My 2014 750 king quad stalls sometimes when I touch or turn the handlebars,the problem has gotten worse,my machine has 475 miles and is only trail ridden,I have a new factory battery and i have 14.2 volts when the quad is running and 13.3 on the battery when not running,also using a multimeter there is no change in volts when turning the bars until it does stall,If I pull the 40 amp power steering fuse it will not stall.......I've been told its the ECU,Hate to buy one if thats not the problem,but its kinda leaning towards that,,,,,need some opinions.

    • By Corky L Leazier
      One day went to start and nothing, the fan comes on cause its straight wired ,but no lights and no all the fuses show no power with the switch on. Changed starter relay nothing changed thinking maybe switch next and how can I test it.
    • By Denis Lanthier
      Hi All,
      I have a 2004 Yamaha Kodiak, which has taken me to many remote places and hauled lots of game.  I still love it after 16 years.
      Lately when I go to start it using the starter, sometimes it clicks and kills the power in the display.  Lights don't work, nothing works and I end up having to unplug the battery, wait awhile, and replugging the battery ends up giving the power back.   Using the winch will sometimes kill the power as well.
      Battery is new, all fuses are ok, I'm at a loss.  I can start it with the pull crank and it will work and so will the lights.
      Any insights or advice would be appreciated!
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...