Quantcast
Jump to content

2006 Bombardier Outlander 400 Muffler replacement


Recommended Posts

I have a 2006 Bombardier Outlander 400  that I purchased new.  I use the Outlander for hunting and working around the acreage.
Muffler has worn out with holes in it and I am looking for a replacement.  From what I can find, factory mufflers are no longer available.  Are there any after market mufflers that can be found that fit without having to hire an expert welder to get creative?  
Not looking for high performance, just a good quiet muffler.
thanks
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Forum Topics

    • By JonnyBlaze
      I need to diagnose / replace switch on my Big Bear. It's been intermediate over last few years and finally quit. Nuetral light doesn't come on and have to pull brake in to start. 

    • By huntindog
      I am in the process of puting it back together after replacing the DPS gearbox.
      The manual I have states that it will need to be flashed by a dealer. Is this still true?
      Also , I have a mystery bolt That I cannot remember where it goes. M6x 70 or so.  Hex head with a flat washer.I will try to attach a pic.
      Pic is no go for now....Cox issue I will try again later
      TIA
    • By Slitzer
      Hi,
      Thinking about to upgrade with a performance exhaust.
      Appreciate tips on brands and where to buy (ship to Europe)
    • By lester
      I picked up a 2000 Big Bear 400 4X4 that was sitting around that I know nothing about. It will not start. I do have a red light when in reverse. When I take it out of reverse, I do not get a green neutral light, and when I push the start button the red oil light comes on but there are no noises, nothing else happens. How do I test the neutral switch and/or bypass it to see if I can get it to at least crank? And does anyone have other suggestions for me to try?
    • By ForumIdiot
      Hi, Im dudeman, Trying to get 10 post just to download a pdf. (By the way, how does this not junk the forum up with random post of useless info just to get a download?)
×
×
  • Create New...