Quantcast
Jump to content

  • Do you own an ATV or UTV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Bronco or Race Driven Shocks?


Recommended Posts



Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By chimmike
      Anyone know where to locate these, or generics? The generics I seem to find have the mount on the wrong side versus the hose outlet. PITA!
      Also, is the rear master cylinder rebuild kit any good?
    • By Jride937
      Have a 2002 Yamaha Bear tracker 250, everything was fine then one day just lost power. Battery is fine, have 12.53 volts coming out, but I have no lights no start no anything. Looking for a wiring diagram
    • By BrunoNogueira91
      Hello, I am restoring a bayou 220 here in Brazil, I have a question regarding the rear brake activated by the lever on the left side. The ex-owner connected it in place of the reverse cable and as this is incorrect, could someone show me through pictures where I correctly connect the rear brake cable? Another thing, every time you reverse, is it necessary to activate the reverse key?
    • By diamonddogs
      Hi i bought my first atv last week, mostly for plowing. its a 94 yamaha big bear 350 4x4, with plow, new front axles, carb rebuild and some other stuff for $900. in todays prices, i think it was a pretty good deal. I plan on tearing it down and doing a semi restoration in the summer. its been clearly neglected so i suspect i will need to do a fair amount.
      couple questions. 
      1. parts and manuals, so far i know it needs front shocks, tie rods, brakes, cables, lots of small stuff, whats your guys favorite online atv parts store? where can i find a good repair manual?
      2 - starts and drives great, shifts a bit hard? not sure whats normal because i dont have a point of referance. i have to almost lean back in the seat and lever my foot up to get it to shift, seems like there is either alot of play in something (shift lever itself is tight) or there is a long travel, or it just dosent want to shift. also the hi / low / reverse lever needs to go past the gate a bit to actually shift into gear, and seems to need me to shift into nutral before shifting into reverse (not sure what your supposed to do). also wondering a bit about the history of the machine, because the plastics have a slot for a dash mounted shifter, but the one on it is a gated shifter right above the pull starter. 
      3. seat and plastics repair, seat is quite torn up with a seat cover over it, plastics are pretty cracked up, these items i havent found replacements for for any reasonable price, i dont care a whole lot about asthetics but whats the best way to functionally repair these things? is there reasonably priced replacements somewhere? i plan to bedline the whole thing after im done. 
      4. there was no title, but i did get a bill of sale, will it be difficult to get it titled / registered? (im in mn)
      thanks in advance for your help, looking forward to being part of the community

    • By AKMichael
      Hello All,
      I have a 1999 Yamaha Big Bear 350 4x4 trying to get fixed up so my grandson can go out in the woods with me.
      We have owned it over 10 years.  It got harder to start, until it finally would not.  Replaced the carb.  Right afterwards, it started and ran nicely, but after turning it off, would not restart.  Tonight I used starting fluid and ran, then died.  Adjusted the idle up a little, used more starting fluid and ran great.  It idled about 15 minutes.  Turned it off, and restarted.  Ran it around the yard about 5 minutes.  Turned it off, and would not restart.
      Any ideas or suggestions would be greatly appreciated!
      Thank you. 
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...