Quantcast
Jump to content

  • Do you own an ATV or UTV? Join our Forum!

    Join QUADCRAZY ATV Forum today for FREE! We keep these forums clean and user friendly. All first posters will have to wait to have their content reviewed and approved. Once your first post is approved, you will no longer need to got through an approval process. To gain immediate approval and a NO ADS experience, consider subsribing to our Premium Membership.

2014 Sportsman Forest 850 Decals Needed


weblex
 Share

Recommended Posts

Hi. I'm owning 2014 Sportsman Forest 850. Due to operation there is a problem with the decals and I would like to update them. But, as it turned out, this model is rare and finding the necessary stickers is a very difficult task, especially considering that the part of the decals set that I'm looking for is no longer produced - number 2 on the pic below with part number 7179065.

I've tried to contact Polaris support asking them to sell me this decals or send image in any possible format to print by myself but unfortunately no luck and it's sad, because I have owned various models of Polaris for over 10 years and a fan of this manufacturer.

Perhaps someone can send graphic files so I can print the stickers myself or show me how to get them?

Or is there another solution to this problem? Small fresh decals make the ATV look completely different.

Thank you in advance for any help or idea.

 

image.png.679470c2dc1d97edc253f45319870e6a.png

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Similar Topics

    • By sheba2012
      Replaced pump and sock along with the filter still only 15 lbs of fuel pressure any ideas?
    • By Thegrizz
      So, I just bought this quad off a acquaintance of mine… anyways, it’s missing the airbox which I’m trying to purchase if I could only figure out the year and what model of lt230 it is due to having only 9 visible digits for a vin…guy said he had the title at one point and lost it when he moved houses after the flood of 08 in Iowa….I just desperately need to know what model this thing is so I can start getting to work on it….it does run after a good carb cleaning….I’m having trouble getting it to idle though due to essentially just having a rigged up air filter with no airbox on the bike…I’ve sanded down the plastics and it looks like the original color was orange and the seat I believe is either from a different Suzuki or it’s been painted gold and black? The plastic nose part is originally black…it has the lever for reverse by the sprocket it has a pull string to start and I think originally it has electric start as well….idk I’ve had to bypass and use a screwdriver on the starter Solenoid to get it to start …someone has definitely done some rigging with the wiring as well.but if anyone has any clue what I need to look for to identify the year and actual model so I can get the right stuff. I’d appreciate it.



    • By DonB
      Fuel Injected, 2015 AC XR550XT ATV (renamed the Alterra from 2016 on).  1300 miles.
      I had written an earlier post concerning part of the problem, but a new one has arisen...
      2 PROBLEMS:
      Engine sputters & fails when throttle applied (even from idle and while in Neutral), and, now... Fuel pressure reads @ "0" despite clear line and operational fuel pump. Unit originally suffered fire in muffler - presumably due to engine driveability problem & resulting unburnt fuel... fuel pump ultimately died when starting repairs.   Installed a new fuel pump as dealer advised it was the problem. Have now been chasing a proper fix for several months, as, while it generally starts fine, the engine will not take any sort of throttle - even from idle. Instead, it immediately starts to miss, backfire & die.   From the beginning, the dealer claimed that a new genuine AC fuel pump was all that was needed. However, the replacement, non-AC fuel pump runs at 42 psi & works fine). NEW ISSUE:  Unexpectedly, the first replacement pump stopped registering any fuel pressure (per in-line pressure gauge). This despite confirming both: (a) pump clearly pumping & (b) fuel line - all the way to the fuel injector - clear & delivering fuel. Tried a 2nd replacement pump which, initially, registered pressure (engine performance issues remained). But, when I tried to start it today, no fuel pressure again (and, therefore, apparently no fuel to injector). Again confirmed pump working and fuel line to injector clear & delivering fuel. Engine continues to start easily with starter fluid but, of course, stalls once fluid has burned off. While cleaning/replacing the fuel injector seems the next logical step, it strikes me that, were the injector plugged, I should still be seeing a psi reading on the installed, in-line gauge I've been using (not zero)!
      Any ideas before I surrender this to the dealer and a B-I-G bill?
      thanx, db
    • By ridindirt1965
      Replaced clutch bearings........ either not getting enough rpm's or the belt is slipping any known information would be appreicated 2004 90 sportsman...............
    • By Yamaha250
      I have a 1999 Yamaha bear tracker 250 that needs  carburetor but I really can't afford a new one right now $650 at the dealer is there an older style o could use that would work 
       
  • Gallery Images

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...