Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

weber

2006 can am outlander 800 maintnence

Recommended Posts

I was wonderin if anyone knew how to resest the display screen. when i do an oil change my fourwheeler still says maintnence soon? If anyone knew how to get rid of it that would be nice thanks

Share this post


Link to post
Share on other sites


Try disconnecting the battery for a few minutes and hook it back up. If you still have the light, then maybe you need to check other maintinence needs, could be a clogged air cleaner or something.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Finsdad
      Im new to the forum and the quad I just got. I want to change oil in in. Its almost impossible to find anything on-line. I know it takes 10w40 and know the oil filter location. What oil should I use? Is there a cross reference for oil filter. The closest dealer to me is an hour away. I have NAPA close and like the WIX or Napa gold filters. Also is where can I get a Manuel for it? Thanks
    • By Trenton
      Hello. I am a new member as of today. I had a quick question to ask. I recently was driving mt HONDA RANCHER 2004 GPSscape 400 and my display stopped working. I was driving the atv and all of a sudden the speedometer and the service lights went out. Also the lights stopped working. I am still able to shift gears, change from 2wd to 4wd, and can still select if I want EPS or Auto. I have checked my fuse box and have changed a few of them around. It did not change anything. I was wondering if anyone had any idea of what had happend. Thank you for your time- Trenton 
    • By Michael Taylor
      Not sure if this is the right place to ask this but I have. 2000 Honda Forman 450es that was my fathers. When he passed away I figured I’d put some work into it. It’s been setting a while but figured it would be a good project for me and my son  
      Just found out that the display speedometer has been discontinued and I’m having a hard time finding one on eBay  I was curious if anyone knew if any other year model would work on this bike ?
       
       
    • By w_r_e
      Can anyone point me to a good set of instructions for changing front diff oil on a 1987 Suzuki LT4WD? I can almost guess which bolts are drain & fill... but I've been wrong before... 😆 
      I found some partial posts on other forums and they linked out to dead images and whatnot. Any help appreciated. 
      This thing is running pretty good, got the front brakes back to life, electric start works fine, seat cover fixed up, plastics stitched back together...
      BEFORE (last week):

      AFTER (today):

    • By Belmontie
      Hi bought this quad with a few leaks and other issues which thanks to excellent advice from these forums I thought I’d sorted them till I washed it down and found oil underneath. 
      It is coming from the seal around the gear changer pedal as it looks like someone has banged the housing flat on one side. Knowing how easily aluminium is broken I don’t wanna risk tapping it back into shape. Would a new seal fit or would the distortion of the housing render it useless.
      thanks in advance 
  • Similar Tagged Content

    • By Kyboy
      Iam looking for help seperating the rear brake drum and the cover. Any suggestions would be greatly appreciate
    • By pickytar
      I have a Chinese Hybird 250 or that's what I was told it was. I found 17 numbers on the frame. Will these numbers tell me exactly what it is that I have? (I know that its a 2006 from a plate on the front)
    • By kiwisteve
      Hi Folks
      MY Ltf 400 has power and electric start turns motor over, but wont start...
      seems no spark
      im told stalled in paddock and wont start again
      any suggestions please
    • By tmaterman
      Hi guys! First post here...bought a Bruin, as mentioned above from a buddy. It had been parked for a few years at his house..unused. Bought it from him at a steal and put a battery in it, new gas, etc...fired right up. It is cutting out now, but I suppose that is just the carb/fuel system needs a good cleaning. Ordered a new carb and hope that gets it going good!
    • By Rktman455
      I have a 2009 800 efi Sportsman and at 30 mph it will cut out, it will maintain 30 but will not go any faster, it is almost like the reverse overide but pushing the button changes nothing in the forward gears. 2390 km on it and I havent had it long. Thanks in advance!
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...