Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Recommended Posts



Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Tagged Content

    • By New2quad
      I just picked up a 2004 Yamoto 70 quad in a trade (for something I was hoping to get $50 for)
      I am told that this is a knock off honda?...
      The guy I got it from said, that he thinks the ignition coil is bad... I think the problem is much simpler & that it's just not plugged in. The attached picture is of under the seat where the battery goes.
      The red and green obviously land on the battery terminals, but where does that square plug go? I can not find any open connectors...
      Could there be a small harness that's missing that also lands on the battery, and connects to this plug?
      Any help is appreciated.


    • By antonye996
      Im trying to find out service details for a yamoto 250 quad. 4 speed with reverse.
      Oils, filters etc
    • By kbsparky
      I am looking for a parts / service manual for a 250 yamoto atv '05 , need to find out if and what kind of oil seal is behind the starter gear. The stator is getting soaked in oil and burnt out once (no longer aval.) had to rewind the ign.pickup coil myself. Just dont want it to happen again.
      Any help would be great.
    • By dark042297
      I have my quad and i has been running very well until my Clutch cable snapped i get a new one but the Clutch has been reversed like when u pull the clutch back the transmission engages when u let go the clutch engages need help
  • Similar Topics

    • By Abbeypalm
      While cruising, my 2011 750 king quad suddenly shut down. As it happened, red lights on the display flashed. Any ideas? My head lights suddenly stopped working about a week ago, if that helps. I have no power at all. Thanks 
    • By Brennon Heflin
      So I bought a 2000 quad runner 250. I'm having some issues an wondering what it could be I replaced the pet cock valve an the fuel filter an pump inside tank I also put a voltage regulator on it. The problem I'm having is that when u give it half or more throttle it bogs down an loses power what could it be the bike is almost like new an cant figure it out any help would be great
    • By smitht18
      Looking for the rectifier.  Most bikes have near magneto.  It appears the KQ has it in front.
      Can someone tell me exactly where it is? 
      Bike not charging and magneto checks out ok
    • By Hunter19
      How are you doing guys I just joined I have a 1998 Suzuki King quad I’m having problems with high RPMs the ATV idols perfectly but soon as a throttle up it doesn’t stall but it just bogs down it has no power any suggestions thanks
    • By Richard Western
      Hi guys,
      I am hoping someone might be able to help me out. My Kawasaki 300 4x4 has an issue where it doesn't seem to want to go into neutral and also it will shift into reverse without using the lockout knob.
      If anyone can suggest what to look at it would be very much appreciated.
      Thanks.
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...