Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Other ATV Brands Forum

Posts about other ATV brand and models and manufacturer specific topics that do not fit in other categories. Chinese and off-brand ATV topics.

140 topics in this forum

    • 71 replies
    • 57,029 views
    • 16 replies
    • 46,326 views
    • 0 replies
    • 149 views
    • 5 replies
    • 230 views
  1. Missing bolt

    • 4 replies
    • 95 views
    • 1 reply
    • 747 views
    • 4 replies
    • 1,425 views
    • 1 reply
    • 782 views
    • 1 reply
    • 1,354 views
    • 1 reply
    • 386 views
    • 5 replies
    • 402 views
    • 0 replies
    • 576 views
  2. Tesla ATV

    • 11 replies
    • 1,006 views
    • 1 reply
    • 880 views
    • 0 replies
    • 445 views
    • 11 replies
    • 971 views
    • 3 replies
    • 537 views
    • 0 replies
    • 2,652 views
    • 0 replies
    • 941 views
    • 3 replies
    • 445 views
    • 1 reply
    • 2,186 views
    • 2 replies
    • 997 views
    • 6 replies
    • 1,242 views
    • 0 replies
    • 556 views
    • 1 reply
    • 1,293 views


  • Latest Forum Posts

    • I can't listen to your movie.. so does this noise happen at idle, or only with a few revs, and does it get louder if you put a load on it, or does it rattle worse when there's no load on it ? In neutral, if you just gently bring the revs up a little and then back down again, does the noise come in as the revs are building up, or as the revs top out and the load comes off it, or is it worse as it slows down again ? And would the noise be at the speed of the piston going up and down, or only every second stroke, so on the firing, or perhaps something in one valve ?
    • Well... Did you ride it before taking it apart ? Could it have had the noise before you worked on it ? What was the original problem you were fixing ? So the timing chain stopped the rubbing noise, that's not the noise you have now ? And.. does it make the noise when it starts up cold, does it get louder or quieter as it warms up ? Did you check the piston pin fit in the conrod ? And are you listening to the noise through a screwdriver to your ear when you say the noise is coming from the top end/valve cover, or is that just where it sounds like from a distance ?
    • Well since the cdi sparks when it wants to I doubt it's faulty. In the smaller models there's a neutral relay that has wires going into it from the neutral and reverse lights and the kill switch and the starter button... If that thing has that relay I'd be checking it out and it's earth wire..  I see in the manual I have here for a 300 that there's also a diode in the neutral circuit.. that might be a suspect too.. You really need a workshop manual and then start tracing the power through one wire at a time going to the cdi unit. Check the neutral switch, neutral diode and neutral relay..  I reckon the problem will be in there somewhere..If your 500 is like the 300.
    • Also does anybody know if the recoil starter is a common part that I can locate as an assembly?
    • Picked up a 98 Quadrunner 500 for a song. It's in rough shape, but funny enough it turned over and fired on starter fluid. Fuel lines are rotted to snot and the inlet tubes to the carb are rusty. I have a rebuild kit for the mikuni, but I'm wondering if anyone has used any of those alternatives on Ebay or Amazon that say they fit? 

×
×
  • Create New...