Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

mav0016

2018 Argo Xplorer oil filter

Recommended Posts

Hey does anyone here know where I can find another brand oil filter for the stock argo filter? Being so new its hard to find anything. Thanks

Share this post


Link to post
Share on other sites


1 hour ago, mav0016 said:

Hey does anyone here know where I can find another brand oil filter for the stock argo filter? Being so new its hard to find anything. Thanks

Do you have the OEM number on the filter that is on it now? is it by chance 12 050 01 or 49065-2071? I took a quick look where I would normally look, but its not an easy lookup. 

Share this post


Link to post
Share on other sites

Can you see the oil filter on your atv and see if there are any numbers on it? Unfortunately that number doesn't cross to anything or come up online. That may be their part number but they may be using an already manufactured filter or engine from another manufacturer. The trick will be to cross it.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By richard fischer
      I have a new 2020 cforce 600 touring and read how smooth the shifting was on it. Mine however, sticks in gear quite often and only after moving the bike around does it finally shift. I use the brakes before shifting as it says but that doesn't seem to affect it either way. Anyone have this issue? Is there an adjustment on the linkage perhaps? Any suggestions are appreciated. The machine is new with about 10 miles on it.
    • By Rich1028
      Gladwin Trails Not What you Expect to Find on A Quad Trail
       
    • By tatjeff
      can anyone help me figure out year and on my grizzly i have no clue rode many of them very first ever owned 

    • By M C
      Hello all!
      A friend of mine has this particular 4 wheeler. It sat in the garage for about a year, so I redid the carb, cleaned the tank and installed a new petcock. So far, it cranks right away whether its button started or pull started. So I have a couple of questions concerning the carb and air filter.
      1. Is this a cvk32 250 or 350 carb? As the air fuel ratio adjustment is different according to a cvk document I read. What's your adjustment setting? 2 whole turns and a 1/8 or 2 whole turns and a 1/2? Comparing the old setting on the carb to the new setting (and where the needle sits now), makes me think it was way off before. 
      2. The Air filter cover, gasket, air filter and plate element are all missing. So I was thinking of removing the hose that goes to the air box and put one of those K&N style looking filters and be done with it. So my question is.. will I have to readjust Air Fuel screw or just adjust Idle?
      It's just going to be driven around the neighborhood.
      Thanks in advance for any info or help. Y'all stay safe out there!
    • By Bleuu
      Hello so I’m new to the atv seen, and was wonder why my stock light didn’t turn on , and it figures that the black and white wire and the black wire were ripped apart everything else is connected fine, what could to reconnect them
  • Similar Tagged Content

    • By Jeff Cotter
      I recently purchased a 2000 polaris xplorer 400 4x4.  When I bought it the starter was bad, speedometer didn't work,  and it had been sitting for 5 years. I replaced the battery, and starter. Changed all fluids, and got it running correctly.  Then replaced the speedometer in an attempt to make sure the awd would be available when needed.  And took it out for a couple hour ride with a buddy.  
      It ran great that ride with no serious problems just a little carb issues which I was able to take care of on the trails.  Then a couple days later I decided to take it out for a ride by myself,  again ran great no issues other than a couple times it seemed to cough and then take off again.  That day when I was loading it I noticed coolant dripping onto the trailer and the overflow bottle was empty.  
      Got home and decided to drain the counter balancer, when I did that I got about 3 cups of coolant. Im guessing that it needs new seals and all for the water pump.
      My question is how difficult is it to do the water pump and should I attempt it or should I send it down the road to the polaris dealership to get it done? 
       
    • By Micah Gafford
      I've had a seriously annoying time trying to deal with the brakes on my rebuild. What size is the fitting that screws into the inverted flair cross and into the caliper? I plan on trying to make parts I need with braided steel hose.
    • By Kyle Meadows
      I am 17 and I don't have lots of money but I know my way around older 2 stroke dirtbikes but my grandpa gave me this four-wheeler and I have had nothing but issues with it. I went through gas tank/lines and the oil injection has been bypassed, I have mixed gas in the tank and it is for sure getting to the carb. I have cleaned the carb to the best of my ability. I can get it to try and start for a few seconds but won't run any longer than 5 seconds with or without ether. Please help
    • By Micah Gafford
      I'm Micah I live in southern Indiana in the Hoosier national forest. Just picked up my first ATV for extra cheap and I've gotta get it up and running from sitting in a friend's shed for a few years. It's a '95 Polaris Xplorer 400. I've had a little bit of experience with simple ATV stuff from the cheap chinese atv my in-laws bought for our kids. I don't expect nearly as many headaches but would love suggestions on what things to go through before putting in a battery, gas, and oil and trying to fire it up.
      Thanks!
    • By mav0016
      Is it normal for a new ATV from the factory to have rock solid suspension? My 2018 Argo Xplorer is stiff as a rock,
       

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...