Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

mav0016

2018 Argo Xplorer oil filter

Recommended Posts

Hey does anyone here know where I can find another brand oil filter for the stock argo filter? Being so new its hard to find anything. Thanks

Share this post


Link to post
Share on other sites


1 hour ago, mav0016 said:

Hey does anyone here know where I can find another brand oil filter for the stock argo filter? Being so new its hard to find anything. Thanks

Do you have the OEM number on the filter that is on it now? is it by chance 12 050 01 or 49065-2071? I took a quick look where I would normally look, but its not an easy lookup. 

Share this post


Link to post
Share on other sites

Argo told me its 11167G

Share this post


Link to post
Share on other sites

Can you see the oil filter on your atv and see if there are any numbers on it? Unfortunately that number doesn't cross to anything or come up online. That may be their part number but they may be using an already manufactured filter or engine from another manufacturer. The trick will be to cross it.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Chad Dickerson
      I am goin nuts here! I have a 04 400 air cooled 4x4 , I'm a atv,car,truck,mower mechanic for yrs,just sayin. Ok it cranks and kinda fires now and again then after 5 min of cranking and stopping itl start if u touch throttle itl did then u start all over! If u let it warm up sumtimes u can throttle it up other times it just does! Just depends on it? When it stays running it runs awesome,no problems except it just does randomly like u shut key off? Sumtimes itl start right back up others itl do the no start thing! IV put new plug,adjusted valves and hot tanked carb? I'm at a loss here guys! Please any other ideas? I don't think it's anything to do with flywheel? It's not the auto it has a hi low reverse lever on left fender and foot shifter? Help please lol
    • By Aaron Ruiz
      Hey I'm new to the Forum but I just wanted to talk about my Scrambler I just picked up and when I first picked it up I thought it was okay but after I got home and everything I noticed it's very hard to shift into drive neutral reverse it is possible to shift into those gears but it's very stiff like and it takes a lot for it to actually engage to move forward. In Drive when I press on the gas it takes a while for it to actually start moving in the RPMs go up before it starts moving I inspected the belt it looks fine to me I checked the transmission fluid and it was low so I put some. I just hope transmission is not out just curious if you guys have any ideas
    • By YamahaGrizzly
      Our new friend shows us what the brand new 2019 Yamaha grizzly 700 can do in the mud! He already started modding up his grizzly to help tackle the mud like never before! The 2019 yamaha grizzly really impressed me and I love the look of the 14" rims along with the 2" highlifer lift!
      We got a few new sponsorship rolling in this year so make sure you keep a look out for that stuff!
    • By EpicPanda Exhibits
      So i purchased a quad runs and drives good but when the quad is off and i try push it the wheels lock up and rotate the engine (its automatic) so i purchased new clutch and still same issue but when i take clutch off and push the quad it turns freely when i install clutch and push quad it rotates the engine as if it was in gear but its automatic... heres a video i found example what exactly my new and old clutch does. and heres link to new part i bought https://www.ebay.com/itm/17-Tooth-Automatic-Clutch-w-Cap-for-50cc-70-90-110cc-125cc-ATV-Quad-Dirt-Bike/192705885823?ssPageName=STRK%3AMEBIDX%3AIT&_trksid=p2057872.m2749.l2648 any help would be appreciated
       
    • By tom reed
      May be some of you guys can help me, I've got a 1990 honda four trax 2 wheel drive, the top end has been completely rebuilt. When I bought it barely ran, so I had everything redone BUT, it shifts good until the motor gets up to running temp and it starts getting hard to shift and the longer you run it the worse it gets, it will get so bad that it is almost impossible to get it into reverse. Does anyone know what wrong?
  • Similar Tagged Content

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...