Sign in to follow this  
fox300exchic

How two strokes really work.

Recommended Posts



Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  •  Like what you are reading? Please help us by sharing this content.
  • Similar Content

    • By Jw7054
      So I went through the top end and then put everything back together and did break in and then probably 3-4 rides. Now my start button doesnt work but i can jump the solenoid and it starts right up. I looked for bad connects and didnt see any. I then replaced the coil and got nothing. So before i blow more money on something i dont know if it will work, i would like your guys opinion on what it would be. Thanks. Oh and it is a suzuki 160 '91
    • By RCNY
      Hi ,I have a 2002 yamaha big bear 400 2WD ,purchased used ,devoloped a oil leak at rear of engine kinda like where the out put shaft goes out ,I kept a eye on oil level while older sons didn't ,long story short ,when I went to start it up one day,it cranked and popped but wouldn't start ,oil level EMPTY,I tried filling it and it ran out as fast as I poured it in,,two questions most likely ate the rings and bearings yes or no ,do you think that fixing that seal will restore enough compression to make it useable and here's a third question who around upstate NY area to do a rebuild or are crate motors available and if so from where ?
    • By hangingon
      I took the old prairie out and had some fun but it was hot today so I cut my ride time down. Came home and was going to rest I knew I should have came in the house & not stay in the garage. Now the xr100's motor is out of the bike and the top end is apart.
    • By stroh41
      On my 05 Sportsman 500HO I just bought the Reverse Override button will not work while riding or will not work to change the Information Display, RPM,Trip, ect... I can get into the diagnostic mode and show V2.1 I think. Is this normally just the switch? Or is the issue usually deeper, possibly Speedo? Any help would be greatly appreciated!!!
    • By TreadLightly
      For the sake of consolidation... Here's a nice place to post Trail Work and Area Clean-up Volunteer opportunities.
      If you're interested in me posting a volunteer opportunity in your area on other forums, please feel free to send me details (where, what, who to contact). [email protected]
      Also, a reminder that if you are a partner/member club or a 3-year individual member, you qualify to apply for our stewardship grants to help fund these projects. Stay tuned to the Stewardship Grants thread, or have a peek at the website: Tread Lightly - Stewardship Grants
      Thanks. And feel free to post up your own stewardship projects here as well