Quantcast
Jump to content

  • Do you own an ATV or UTV? Join our Forum!

    Join QUADCRAZY ATV Forum today for FREE! We keep these forums clean and user friendly. All first posters will have to wait to have their content reviewed and approved. Once your first post is approved, you will no longer need to got through an approval process. To gain immediate approval and a NO ADS experience, consider subsribing to our Premium Membership.

Stator compatibility? LTR450


HappyJack
 Share

Recommended Posts

Evening everyone

With my friends, I'm building a one-person track-day car that is powered by an LTR450. One of the problems we're encountering is the lack of amperage created by the charging system.

Are there any stators that can swap into the LTR450 case to up the amperage? Are there any other methods to up the amperage? Weight is a huge consideration in this, so we can't really run a larger battery.

Thanks

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Similar Topics

    • By chadd7
      I bought a used 2019 ds 70 a couple weeks ago for my son. If I had to guess it has under a 100 miles. It still has the nubs on the tires.

      It starts right up on the first crank. After he rides for a couple minutes it will stall when he stops. If he doesn't stop it won't stall but as soon as he stops it shuts off. I can get it started but it take about 3 minutes of cranking the engine before it will fire back up. Then again after a couple minutes of riding it will stall as soon as he stops. Any recommendations?
    • By TSWIII
      I let my ArticCat sit over the winter but before it was put in the garage it was running perfect. In taking it out this year it wouldn't start. I can start it with a charger and it will idle just fine. But it's doing something weird now. Either the display 1)won't display anything or 2) it will just display the analog speedometer but none of the digital stuff or 3) it will display all. So it was acting really sluggish when in HIGH gear and sounded like it was in low gear. So in driving it down the road and it being sluggish, I switched the ignition key to "Lights ON" and the ATV immediately picked up as though it really was in HIGH gear. Switching the ignition back to "ON" was like down shifting into LOW gear. When I came to a stop and switched from LIGHTS on to just ON the ATV completely died. After a 30 minute ride you would think it would start again but I had to jump it again to get it to start. Same issues with the ignition having to be pointed to Lights for it to run decently. Then just as I got back to home base the display showed VOLT. It acts like it's something in the ignition but not sure how that's related to the gears. I put a gas cleaner in the tank since it's been sitting but it really doesn't seem like a bad gas issue that I thought it was at first. I checked the IGN fuse but it seems fine, replaced it with the extra fuse but no joy. Anyone have any ideas?? Thanks in advanced for any help. It's much appreciated. 
    • By Strike37G
      Quick question about bolt on valve cover (circled). Is this used for any type adjustment or connected to anything or is it a service vacuum port? Wanting to install a vacuum fuel pump and look like a good spot to connect vacuum. Thanks to all.

    • By Mikey69
      Heres my story. Kinda long. I guess I was a late bloomer when it comes to quads. I had never ridden a quad in my life. Rode Dirt Bikes as a kid growing up. Back in Oct of '06 I found a Mustang on craigslist. Took it for a test drive one morning before work. Fast car. 351 Cleveland. I had planned on meeting the guy again after work. For some strange reason thats still to this day beyond me, I stopped in Hillsboro MotoSports on the way home from work. I had 6 Grand on me. There was a left over '05 sitting by the front door. It was on sale for $4999. It was $5499 OTD. I didnt even look at anything else. I knew nothing about quads accept I thought it really looked coool and I had the money in my pocket to buy it. I was sitting on it when the salesman walked up and asked... "Can I help you?" Without hestitation I pulled 60 Ben Franklins outta my front pocket and said "I want this Quad. Load it up in my truck." It was just about dark by the time I drove away from the shop. BTW, I didnt bother to ask my ol lady if I could buy it. LOL. Anyway, I took it by the house and showed her. She was kinda stunned but not mad. We drove over to a friend of mines house and unloaded it. I took it to the field across the street from his house. HOLY CHIT!!!!! I was surprised by the power. I had it for about 2 weeks and took it to Sand Lake. I was there a few hours and rolled it on a banked turn at the top of the bowl right before you get to the one-ways. When it rolled, I flew off and landed on my belly. The quad came bouncing and landed on my back. For a month I couldnt even walk. I was scared of it. I considered trading it for a 250EX. Went back to the shop. The salesman said..."Dude!!! You dont want a 250EX!!! Trust me. Just get used to it" I still wasnt convinced. I put it on craigslist for $4000. Calls were coming in. I had a guy that wanted to come look at it that evening. I decided to take it for one last ride at Browns Camp before I sold it. I was still afraid of it. After about 5 minutes I started feeling comfortable on it again. I decided right then, I loved my Honda 450 and would learn how to ride it instead of selling it. That was late Nov of '06. Work was slow for a Painter in Oregon. My new job everyday? Going to Browns Camp and ridding my Quad. I bought my Girl Friend an '02 Blaster. I rode my 450 for 4-6 hours almost every single day for 3 months. And yes, I know my way around Browns Camp pretty well. LOL. In March I bought her an '06 TRX250EX (Thank God I didnt trade my 450 for one of those) LOL Since then, I have become totally addicted to quads. I love them. Couldnt imagine not owning at least one quad. Luckily I have two. My "07 was $6500 OTD in July of '07. Bought it for my Girlfriend. Traded in her 250 EX. A month later we broke up. So, I wound up with two Honda 450's.
       

    • eManualonline.com Save 20% OFF on orders over $50, Use Code: BLAZE


      eManualonline.com Save 20% OFF on orders over $50, Use Code: BLAZE


      eManualonline.com Save 20% OFF on orders over $50, Use Code: BLAZE

    • By tjakes680
      I have a 1986 quadrunner 230 GE so the problem is I can not get any pressure in front brake lever I know this means a leak possibly or air  but i opened all wheel cylinders and found one with a torn dust cover i had a spare cover and then pulled calipers soaked in brake fluid reinstalled amd still no pressure I can get fluid to come out of bleeders at wheels but cant build pressure Should and what if anything should i chk at master cylinder ? thanks guys 


  • Similar Tagged Content

  • Gallery Images

  • Recently Browsing   0 members

    • No registered users viewing this page.

×
×
  • Create New...