Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

roy11

clutch

Recommended Posts

Hi I am fitting a new centrifugal clutch in a 350 big bear do I have to soak it in oil over night cost a lot of money want to get right first time thanks

Roy

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By ddiggerr
      Hi
      Just picked up a BB for $650 as the PO just threw in the white towel. There is no spark with either the electric start or pull start. The stator is new, new battery, new key switch, new plug.
      I have gone over every wire and cleaned everything and checked all I could with multimeter.
      I'm stumped myself why I wouldn't get any spark with theh pull start.
      Could this be the pickup coil?
      wires coming out of stator are red and white, green and brown, and 3 yellow wires
      I get continuity from red and white but nothing from green and brown or the yellows
      Its a hair puller and hoping its just the pickup coil and not the cdi
      thanks
    • By Lellwyn Griffin
      I need to replace the starter solenoid on a 2000 Bear tracker.  The OEM is about $70 and aftermarket ranges between $10-$20.  Should I buy the OEM or is there an aftermarket brand that is good?   
    • By Thunt56
      How do I replace the pinion clutch shaft in a 1987 Suzuki LT230 quadrunner? It starts up on the first kick but when I put it in gear it wants to kick up. I can give it gas and put it in gear but my clutch lever isn’t doing anything. SOS
    • By oleskool
      Looking for the service manual for a 2007 big bear 250.
      I have searched the forum for it but cant find it anywhere. If anyone has one or can direct me to the right page would be much appreciated.
    • By Pete Barber
      Pull in clutch lever shift into gear and nothing happens ... But When I pull in the clutch lever I hear a clicking sound ... never heard this before ...
  • Similar Tagged Content

    • By Thunt56
      How do I replace the pinion clutch shaft in a 1987 Suzuki LT230 quadrunner? It starts up on the first kick but when I put it in gear it wants to kick up. I can give it gas and put it in gear but my clutch lever isn’t doing anything. SOS
    • By Steve Howard
      My Hawkeye runs great just wont pull could this be the breaking clutch or the drive clutch thanks for any help
    • By David Vance
      I just bought a 86 Bayou 300 and when it’s running and you shift into a gear the engine stalls and dies. I throttle it up little and it will run and move but the transmission slips really bad. As long as I’m just a little over idle it will move but slips with any more throttle. I’ve been reading that this is probably a centrifical clutch issue. I’ve found an aftermarket clutch for an 88 model but can’t find one for a 86. Are these the same? 
      Any help would be appreciated. 
    • By Pete Barber
      Pull in clutch lever shift into gear and nothing happens ... But When I pull in the clutch lever I hear a clicking sound ... never heard this before ...
    • By Bubba Blaster
      Hi there, new owner to a Bayou 220 and could use some input from those who have owned these. At idle only, I am hearing a distinctly noticeable amount of chatter noise coming from the lower right side of the engine - right in the the clutch housing area. It's like a light clanking sound like something is loose in there. It goes away as soon as you give it throttle. Shifting in and out of gear is smooth and there is no change in the noise if you have it in or out of gear. The clutch doesn't slip at all, it's just that noise. I can also feel it when my hand is on the the clutch housing.
      I just replaced the oil and filter with 10w30 motor oil per spec. Any thoughts?
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...