Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

ron755

tail light problems

Recommended Posts

On my 2003 Arctic Cat 250,   with the headlights on, I have no tail light /no stop light.

with headlights off, I have brake lights, no tail lights. Where should I start looking for my problem?

Edited by ron755
double checked

Share this post


Link to post
Share on other sites


Start by  checking the  ground wires  for the tail  lights. I would suspect  there is corrosion preventing a proper ground. The  tail  lights  are feeding  back through the common power  wire connecting headlight and tail light .. When  headlights are on  that  circuit is powered so it cannot  act as a  ground.

  • Like 1

Share this post


Link to post
Share on other sites

Thanks for the help. My tail light was  rusted  inside,and was not getting a ground. Rusted so bad, I'm going to have to replace the whole thing. Thanks again.

Edited by ron755
my reply was not complete

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By amelia slabbert
      Hi I have a YAMAHA RAPTOR 660R 2003
      I have taken of my Air filter and sprayed in my air inlet some carberator cleaner while starting it. That causes some problems. It struggles to start now. Please look at my attachedment video. 
      What can I do now.? 
      MOV_1402.mp4 MOV_1401.mp4
    • By seacoast603
      2014 Polaris Sportsman 400 HO
      We had an issue with the lights working on occasion.  Then they just stopped working completely (front and rear). We looked at the EFI fuse and it was melted, but not blown.  We replaced the fuse, but now the ignition will not turn on UNLESS we pull the fuse out...and BTW, the lights still didn't work with the new fuse. Any help would be appreciated. Thanks!
    • By JacobSlabach
      i know this isnt an atv but same type of thing.  I have a riding mower im fixing and selling for my aunt and it has a dead battery.  i jumped it off my atv and when i turn the key nothing at all happens.  i tried jumping the relay still nothing.  this is with the seat down.  you wouldnt think this mower would have issues as its a top-of-the-line brand and almost brand new (aunt found it for a good price, still got tits on tires, just sat for a couple months in a mechanic shop
    • By Coral Breding
      I loosened the allen bolts on the carrier and when I went to put my driver in the alot to pull back and tighten the chain, I noticed the holes were facing the front of the bike. I tried to slide a driver in and tighten the chain but the thing would not budge. I nearly ripped the tip off the driver in the slot. Any suggestions? 


    • By Shadow soul60
      So I want to put LED headlights in my 99 Bayou 220. The stock headlights have some issue in the connector and they only work some of the time, so I want to replace them with LED light bars. I want to run them off the high beam switch. Which wire would this be?
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...