Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Sign in to follow this  
oxidized_black

2003 Yamaha YFZ350 Parts Manual

Recommended Posts



Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Topics

    • By Asen_77
      Hi All,
      My name is Asen and I am from Eastern Europe, Bulgaria. Riding a Yamaha Raptor 700R and this is my first Quad wanted for a vey long time :)

       
    • By amelia slabbert
      Hi I have a YAMAHA RAPTOR 660R 2003
      I have taken of my Air filter and sprayed in my air inlet some carberator cleaner while starting it. That causes some problems. It struggles to start now. Please look at my attachedment video. 
      What can I do now.? 
      MOV_1402.mp4 MOV_1401.mp4
    • By Coyote251
      View File 2000 Yamaha Big Bear YFM400 Owners Manual
      This manual contains all information for owners of this vehicle including operational directions, safety and maintenance procedures
      Submitter Coyote251 Submitted 03/22/2018 Category Yamaha ATV  
    • By AFricks88
      It will not turn over with starter and will not fire while pulling pull start.
       
      The only thing that Ive tested that didnt test correct is the kill switch I read on another forum to test black and Black/white wire for continuity when in off position I did and it shows continuity like it should. Then when you slide it to run it should be open and show no continuity which mine still shows it while in the run position. So I unplugged the CDI just for sakes of doing it and the kill switch then tests correct. So where should I test next without unplugging CDI?
    • By Lellwyn Griffin
      I am looking for pictures of your carburetors, specifically looking for what type and where the hoses go on the red circles.
       
       
      Sent from my iPhone using Tapatalk
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...