Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

quademane

1989 yamaha warrior 350

Recommended Posts

ok, I tried everything I can think off. I was out riding yesterday and it died down like it ran out of gas. I bought it a couple weeks ago had a brand new carb put on. the E brake is already eliminated. when I rev it up it just sits there and sputters. if I pull the choke out just a little will rev up a little more. I pulled the carb off cleaned all the jets with carb cleaner used a allen key too go down into the jets just to make sure. made sure the flow of gas was good. made sure the gas line was good. and when I fire it up starts right up idles fine but full throttle just sputters. you can ease into the gas and it will rev up just a little and continues to sputter. I'm stumped. it is completely stock bike. there is nothing you can see I'm the carb that could be a possibly problem. thing looks brand new inside and out. I did everything that the forums said online. with similar problems. the old owner did say he never jetted the new carb. but I don't know much about that.

Edited by quademane
add more

Share this post


Link to post
Share on other sites


ok, I tried everything I can think off. I was out riding yesterday and it died down like it ran out of gas. I bought it a couple weeks ago had a brand new carb put on. the E brake is already eliminated. when I rev it up it just sits there and sputters. if I pull the choke out just a little will rev up a little more. I pulled the carb off cleaned all the jets with carb cleaner used a allen key too go down into the jets just to make sure. made sure the flow of gas was good. made sure the gas line was good. and when I fire it up starts right up idles fine but full throttle just sputters. you can ease into the gas and it will rev up just a little and continues to sputter. I'm stumped. it is completely stock bike. there is nothing you can see I'm the carb that could be a possibly problem. thing looks brand new inside and out. I did everything that the forums said online. with similar problems. the old owner did say he never jetted the new carb. but I don't know much about that. I also ran it with the air box off it didn't change nothing.

Share this post


Link to post
Share on other sites

Topics merged and moved to Yamaha ATV Forum.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×