Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Recommended Posts



Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Forum Topics

    • Best/ Cheapest site/ place to get parts

      I live in north Phoenix, Arizona. I just recently got a 1987 moto 4, YFM350ERT. Where would be a cheap place or website to get parts? I know I will need a few things. I'm looking into finding a manual for it so I can get right stuff but that seems to be difficult. thanks

      By William Waterworth, in General Talk - Anything Goes!

      • 5 replies
      • 228 views
    • Prairie 650 KVF-650 Service Manual 2002-2003

      View File Prairie 650 KVF-650 Service Manual 2002-2003 Prairie 650 2002-2003 Service Manual Submitter 87tecate4 Submitted 07/10/2018 Category Kawasaki ATV  

      By 87tecate4, in Kawasaki ATV Forum

      • 1 reply
      • 180 views
    • Polaris Online Parts Catalog

      Here is the Polaris online parts catalog, looks like you need to register with then first. I haven't used it since I'm not a Polaris owner and don't need any parts right now... http://parts.polarisind.com/Browse/Browse.asp

      By Ajmboy, in Polaris ATV Forum

        
      • 7 replies
      • 7,238 views
    • Cannot find a service manual 2005 Kawasaki Prairie 360 2x4

      I most have a rare ATV, because I can not find a service manual without paying money to Kawasaki.  It's a 2005 Prairie 360 2x4.   4x4 manuals are all over the place, but nothing for a 2x4 .  Heck, Bike Bandit doesn't even list parts for a 2x4.   Any suggestions besides paying Kawa.  My machine is in limp mode and I've yet to find an applicable video or even procedure. 

      By Quad Bug, in Kawasaki ATV Forum

        
      • 6 replies
      • 258 views
    • Used OEM parts available by MPN

      Used ATV parts available from Resurgence Small Engine Inc. All parts have been identified by manufacturer's part number, photographed, and listed on our website. Our used OEM parts are available for up to 60% off dealership prices. This way you can maintain your machine with well-made OEM parts at a more affordable price! Compatibility can be confusing, but we’ve simplified it for you. Browse our current parts inventory by type, make, year, & model or search by OEM part number. We make the logistics easy with our Free Shipping Promotion on US orders over $100! Visit our website to view our current inventory:
      https://resurgencesmallengine.com/parts/ Parts are located at Resurgence Small Engine Inc. in Wasilla, AK. Free local pick-up is available and our website is configured for domestic US shipping. For international orders, please contact us. More parts & models to be listed continuously! As of August 2018, parts are available for the following ATV models: Parts are listed for many models, currently including: Kawasaki 2003 KFX400 Polaris 2010 Ranger 500 4x4 HO EFI Suzuki Quadrunner 250 LT4WD 250 LTF250 500 LTF500F King Quad 250 LTF4WDX 300 LTF4WDX 450 Quadmaster 500 LTA500F 4x4 Eiger 400 2x4 400 4x4 Ozark 250 LT250 Vinson 500 LTA50F Yamaha Banshee 350 Big Bear 350 Raptor 350 Warrior 350 Wolverine 350 More parts & models will be added continuously! Resurgence Small Engine Inc.

      By Resurgence Small Engine Inc., in ATV For Sale? Post it here.

        
      • 4 replies
      • 390 views
  • Similar Tagged Content

    • By gpenberthy
      my o4 polaris 4x4 lost power just going down road at 10 miles an hour . Had only been on it for 20 minutes. Engine still ran just no power. Shifted into reverse had little power. Shifted back in forward and it ran for about 5 minutes then no power again. Was afraid to drive it any further so towed it back to cabin while still running..  It had power once again for a few mintues. No smell of anything burning . Several years ago I had to replace belt becasue it did something similiar. Could it be the belt again?
       
    • By Corbean
      I have a 2007 atv 400 after a new battery and solenoid starter all checked out along w fuses .. the atv shows no electric no power... any suggestions? Thanks in advance
    • By Alan Callison
      Hi ya'll. I just got a 04 Kodiak 400 and Im confused.The left rear wheel moves like the bearing is shot so I figured its a quick fix. Much to my dismay when I looked at it before I tore into it ,it appears to have a drum brake-no bearing on the wheel. As this is the first time Id be working on a 4 wheeler job Im a bit hesitant. The manual only shows this has disk brakes.Its a sealed drum right behind the wheel.I pulled the wheel of expecting to find a bearing.Nope! Ive never done it before but it appears Ill have to pull the axle out to replace the bearing. Am I correct and if I am can anyone give me some advice on how to do it.The repair manual isn't much help. Thanks alot!
    • By Chayse Hill
      I have a 2003 LTZ 400 that i bought a few days ago. The quad was running fine until last night. I let my brother ride it down the street and back and i didnt notice anything etong with bike. Then my neighbors friend came over and said "can i ride it?" I said "sure" so he ripped it down the road all fine and when he got back it died right in front of us. My brother said it was dieing on him also. He also said that he wasnt using the clutch to shift. I told him he was an idiot. Im throwing that in there incase that caused a problem as well. But today i go to check it to make sure its getting fuel which it is and replaced the spark plug incase it wasnt getting spark but it is. So i started it and it was having a problem starting then i got started and was reving at idle high. So i took it around the block and it died on me a little bit down, so i try to restart it and it started so i kicked it into 1st and it kinda launched on me and started going with the clutch all the way in. Then it died right after and wasnt running right during that process and was idleing all over the place and just died and now i cant get it started it again. Before it would start without the choke or priming it. It would start real quick now i cant figure if it needs to be rejetted or something else. Air filter looks clean also. But any help would be gratelly appreciated!
  • Recently Browsing   0 members

    No registered users viewing this page.


×