Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

weldsports

1983 LT125 Suzuki rear wheel needed

Recommended Posts

I am looking for 1 or 2 Rear wheels for a 1983 Suzuki LT125 4 wheeler. It is hard to find parts for but it just doesn't quit going. One of my wheels is bent, rides poorly and leaks air.

The wheels are 8 x 8 or 9 wide 4x4 backspacing roughly.  The wheels have 6 bolts, 3 to hold the 2 halves together and 3 to hold the wheel to the hub.  It uses 11.00x22x8 tires

I would also like to find good rear fenders for it if possible.

Thanks very much for any help

[email protected]

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By jimybud
      Below is a quote from a response to similar question from yesterday: 
      "Easiest thing to check is trash in the main jet.  if it idles fine, then the idle circuit and low speed jet is clear.  if it bogs off idle that's when it's transitioning to the main jet." 
      I will go ahead and open up the carb and check the main jet, but please respond to this post as if the main jet is squeaky clean.
      Below is my post:
      Only starts and runs on Full chock. 
      Does not matter what position I have my "mixture" screw.   Tried it at zero, 1 turn, 2 turn, up to five turns.  Spent a few hours confirming that the position of the mixture screw does not resolve issue.
      Runs great at idle and if I slowly engage throttle, it will rev up as expected.  But, quick rev up or when I am trying to drive it, it spits and sputters and looses power.
      I also use a propane bottle and did not find any obvious leaks, and the vacuum port is hooked to fuel peacock and I also made sure to simply block the port with my finger to see if that would resolve the issue.
      New Carb (after market), New Coil, Fresh Gas.  No leaks at manifold boot, hot battery.  Good gas flow.    Runs too good to be a valve issue, or cylinder, great compression.
      I can move the choke out a tiny bit, and it will still run, but will still bog down when I try to power it up.
      I also have a 250 trail boss Polaris that I require to run at full choke, but it has power at all throttle potions.
      I suspect it is running rich as the choke is on, but will not run with it off.
      Any details would be appreciated.
    • By Hunter19
      How are you doing guys I just joined I have a 1998 Suzuki King quad I’m having problems with high RPMs the ATV idols perfectly but soon as a throttle up it doesn’t stall but it just bogs down it has no power any suggestions thanks
    • By Venom
      Does anyone make aftermarket engine parts for the Suzuki Quadsport LT-Z50?
      Pistons, Valves, etc...?
      I have found rings and complete gasket sets.... I need an oversize piston kit and valves..
      One company is selling a piston, but upon further inspection it is an LT50 piston that they are saying is for the 2006 Suzuki Quadsport LT-Z50. Yet the LT50 Piston is not interchangeable with the LT-Z50 according to the pistons listed by Suzuki.
      Any help would be appreciated
    • By Venom
      I am working on a friends 2006 Suzuki LT-Z50 that they purchased not running. I took apart the carb to rebuild it and someone had already been in there... They really destroyed the Air/Fuel Mixture opening in the body of the carb.. It is in no way repairable.
      I have not been able to find an aftermarket carb to fit this model.
      Does anyone know if an aftermarket carb is available?
      Thanks for any help.
    • By mkibbe
      My 2014 750 king quad stalls sometimes when I touch or turn the handlebars,the problem has gotten worse,my machine has 475 miles and is only trail ridden,I have a new factory battery and i have 14.2 volts when the quad is running and 13.3 on the battery when not running,also using a multimeter there is no change in volts when turning the bars until it does stall,If I pull the 40 amp power steering fuse it will not stall.......I've been told its the ECU,Hate to buy one if thats not the problem,but its kinda leaning towards that,,,,,need some opinions.

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...