Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Tom Blank

2018 570 Sp EPS

Recommended Posts

I know this seems to be a problem at times but how often has anyone had the fuse blow on their EPS? Mine did the first time 15 minutes after I bought it when unloading it off the truck at home. Should I be worried about it blowing often or is it just a rare occurrence? 

Share this post


Link to post
Share on other sites


Talk to dealer. Should be under covered warranty. At least have them check it out

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By JimandJacki Cariolano
      Hello to the group, I am working on a 96 timber wolf. Runs great until it gets good and warm then starts missing and puffs smoke and dies. Plug then is black and sooty. Clean plug and let it cool and then it runs fine again until it gets warm. Engine has decent compression, carb it clean. What am I missing?
    • By Rooftop777
      Can't figure out whats wrong, battery good, charging fine but speedometer needle flashing. I know my fuel sending unit is not working but atv was working well last year. Now it was blowing fuses. I did engine code check but none there. Gas gauge flashes and shows FUEL in capital letters. Need help as just cannot figure this out,
      I might pull the fuel pump out and put new float as likely saturated. Don't know if that would give me all these problems ??
      thanks
    • By bodon
      Anyone know what the fuse terminal marked UNSWITCH  does  .  Even with the key off it is causing a drain on my battery and I'm trying to figure out  what that terminal goes to.  It's a 10 amp fuse. If I pull it the "short" goes away.  Thanks in advance.
    • By Jeff Miller
      I'm trying to troubleshoot a starting issue. For a while, maybe a year sometimes I would hit the starter button and I'd hear a single loud click, but the starter wouldn't turn. Usually if I could pull the pull start or roll it in gear it would then start. (now I'm thinking that was coincidence) Now it only clicks. I tried to check what I could, battery is good, solenoid clicks strong, cleaned all connections (which were 80% clean anyway). I started thinking the starter wasn't spinning. I pulled it and it spins freely. The gear that it contacts in the engine-I can wiggle it maybe 1/16th to 1/8th inch back and forth. When I reinstall the starter I feel it jerk when I hit the button. I'm thinking maybe it's the starter clutch? It seems when there's a problem with them they usually just spin freely and don't engage at all. Is it possibly something is causing it to lock? I'm a bit lost now.
    • By Outkast7222
      Well been lurking for a couple years, figured its time to say hey! Been riding in MN since the early 80's been on just about anything and everything with a motor. If you are from the area hit me up! Currently riding a 2018 Sportsman XP 1000, but thinking of going to a General or possibly a Maverick Trail.
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...