Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Pittmac68

New ATV'r

Recommended Posts

Greetings all, Inherited a 2011 King quad 500. Been using it on the hills in the Allegheny forest. looking forward to using it for hunting. Lots of good info in the forums. Cheers!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Curtis01
      OK, sooo  I finally did the old skid plate and screen removal to clean out my oil sump during an oil change...  This bike only has a couple thousand miles on it.  Runs like a top still...  Very few issues over the years after buying it used.
      But boy I wasn't expecting to see this!  Piece of a circlip, stuck up in the screen, and a another shard of metal and maybe a piece of gasket material.  Nothing in the oil but that...  Pristine otherwise, and still runs like a top.  Always has.
      Soooo, is it a wrist pin clip?  That's the only thing I can think of like this that could end up in there.  But definitely wanted to throw it out to guys that have seen the innerds of these more than I have.
      The valves on this thing are still within the factory spec even.  Been a really good lil workhorse...
      Any other ideas?

    • By Countryboy57
      Hello I’m new here and I need help finding out what kind of quad I recently got for free. When I looked up the vin all it showed was 2004 and made in China. Any help will greatly appreciated thanks.
       

    • By BuckBilly
      Good morning to all !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
      Let's see if we can make this a daily event.
    • By technofarmer
      Hey there, i have recently put a new drive belt on my 11 Polaris Sportsman 500 H.O.    It has 44 miles since putting the new belt on and should be nearly broken in as i hear it takes 50 miles to do so?  Anyhow it has had a little trouble with slipping since i put the new one on a few months ago. Now whenver i go down a hill the belt seems to be getting caught in one clutch if not both and then it has to run a high rpm just to go a low speed.  Today it did that again going down hill, i stopped, put it in neutral and when going back up the hill i had to turn it off, put it in neutral, let it roll back down the hill a little, then restart it, low range and it was slipping but thankfully i was able to make it up the hill. 
       
       So what might the problem be? Is this a need for another new belt? New clutches and belt? Or just get something else? BTW the brand new belt i put on it, is a factory one, an exact replacement for the original.   

    • By edb6969
      Hey yall,
      Is any one on here from southern california?
      Im from San Diego .
      Looking to see if anyone from my area is here.
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...