Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Justin Johnson

2010 Brute 750 belt light will not reset

Recommended Posts



Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Ben Cramp
      I am hoping one of you knowledgable people can answer this for me. I have a yfm200 moto 4 engine I want to put in an off road go kart. I would like to mount a sproket where the drive exits the case before the u joint so that I can get rid of drive shaft and make engine bay compact. To do this I would mount engine 90° to axle but would also need to tilt it forward 15° to account for the angle the drive exists rear of casing. Would that be ok? Would oil pump etc still work. Any advice greatly recieved.

    • By Bleuu
      Hello so I’m new to the atv seen, and was wonder why my stock light didn’t turn on , and it figures that the black and white wire and the black wire were ripped apart everything else is connected fine, what could to reconnect them
    • By Tiffany Rowland
      I am working on a Honda sportrax I just got my daughter for get birthday and the reverse and neutral light are not working. When I traced the wire down I saw that it wasn't plugged in but I don't see where it is supposed to connect. Does any one have a general idea of where I should look?

    • By Duane Steward
      I purchased a CDI box from Ebay that was listed as the one for a 200trx with round plug.....when I plugged it in the reverse light stays on.....what did I do wrong ? or is it just a bad CDI box?
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...