Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Jordan Ellison

New to forum but not atv`s

Recommended Posts

hello all I  just found this site on google and i figured I would check it out. I have a rzr xp1000 but recently got my nephews a sportsman 110 efi for christmas so here i am :)

 

Share this post


Link to post
Share on other sites

Welcome to QUADCRAZY! I noticed you had two images that were posted but did not show up. I removed them, looks like you may have added them and then deleted the attachments. RZRs are very cool, a buddy of mine has one and loves it.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Curtis01
      OK, sooo  I finally did the old skid plate and screen removal to clean out my oil sump during an oil change...  This bike only has a couple thousand miles on it.  Runs like a top still...  Very few issues over the years after buying it used.
      But boy I wasn't expecting to see this!  Piece of a circlip, stuck up in the screen, and a another shard of metal and maybe a piece of gasket material.  Nothing in the oil but that...  Pristine otherwise, and still runs like a top.  Always has.
      Soooo, is it a wrist pin clip?  That's the only thing I can think of like this that could end up in there.  But definitely wanted to throw it out to guys that have seen the innerds of these more than I have.
      The valves on this thing are still within the factory spec even.  Been a really good lil workhorse...
      Any other ideas?

    • By technofarmer
      Hey there, i have recently put a new drive belt on my 11 Polaris Sportsman 500 H.O.    It has 44 miles since putting the new belt on and should be nearly broken in as i hear it takes 50 miles to do so?  Anyhow it has had a little trouble with slipping since i put the new one on a few months ago. Now whenver i go down a hill the belt seems to be getting caught in one clutch if not both and then it has to run a high rpm just to go a low speed.  Today it did that again going down hill, i stopped, put it in neutral and when going back up the hill i had to turn it off, put it in neutral, let it roll back down the hill a little, then restart it, low range and it was slipping but thankfully i was able to make it up the hill. 
       
       So what might the problem be? Is this a need for another new belt? New clutches and belt? Or just get something else? BTW the brand new belt i put on it, is a factory one, an exact replacement for the original.   

    • By DMC66
      I need a repair manual for a 2004 and a 2005 sportsman 90 and I found a 2006 manual for cheap money. Is it worth getting and will it cover everything for the 04 and 05
    • By colin james
      View File 2017-2019 sportsman 450/570 with eps factory service manual
      This  is the factory service manual for the 2017-2019 factory service manual for the sportsman 450/570 with electronic power steering 
       
      Submitter colin james Submitted 09/06/2018 Category Polaris ATV  
    • By bren7176
      Doeas any have the actual electrical diagram for the distirbution block  for this atv > I had a few wire not worky worky so needed to replace ends plus dam thiing is dirty so needs to clean all the contacts ..
      Want to make shure I get eveything back in right place .... I have the repair manual but as we know it no help really .....
       
      Brendan
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...