Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

JD430

Can Am 850 XT vs. Polaris 850 SP premium

Recommended Posts

Time to trade in my 2009 outlander 650 XT. I’ve always been BRP for sleds, and this 650 owes me nothing just ready to trade up. I feel compelled to stick with cam am, however, the Polaris 850 sp premium really caught my eye at the dealership. Looking for some real input from real people on opinions on the 2 options. The 650 outlander has been great to me, I use the quad for crop scouting on our farm mostly, the only thing about the 650 is it seemed like it runs a little on the hot side at the slow speeds. Wondering if anyone knows if the newer big v twins cool a little better now. What about the Polaris what are the thoughts there? I really like the looks of the Polaris, I think it’s a really sharp ride. Really the biggest thing is which is more dependable, since I use for work I don’t have time for it having glitchy issues. I also like to be impressed when I snap the throttle, of course... that’s the reason I want to go to an 850 :) thanks in advance! 

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Rooftop777
      Can't figure out whats wrong, battery good, charging fine but speedometer needle flashing. I know my fuel sending unit is not working but atv was working well last year. Now it was blowing fuses. I did engine code check but none there. Gas gauge flashes and shows FUEL in capital letters. Need help as just cannot figure this out,
      I might pull the fuel pump out and put new float as likely saturated. Don't know if that would give me all these problems ??
      thanks
    • By Chase Cook
      Have a 2001 polaris sportsman 500 4x4 atv and when I put coolant in the radiator it starts leaking from the exhaust. The valves are sealed but it stopped making compression. Do I need to just replace the head? I just rebuilt the hole top end and this is the only thing +valves that I have not replaced and was wondering if that is why it's not starting up. Need answers please.
    • By fishinnnc
      I just bought this thing and got the carb all cleaned today and it was running like a champ. There was a spare hot wire hanging down that was not hooked up to anything. I found it when I took all the covers off and did the carb work. Unfortunately I forgot it as well when I fired her up after cleaning and replacing the carb. While I was running her, the wire was lying across the exhaust pipe. The exhaust got hot, melted the insulation and next thing I know I see sparks flying everywhere Bike immediately shut down and all lights went off. I have nothing on the console now when I turn the key over. I fear I have fried my ECU. I found one fuse back by the box, a 30 amp, but it was good. Are there any other fuses on these things? Is there a way to test the ECU? Could it be the rectifier or voltage regulator?
    • By JacobSlabach
      Hey so i sold my 04 rubicon and wanted something new so i went to NC and bought a '13 scrambler 850XP LE EPS.  love it the only issues with it when i bought it were a leak in the front tire and the mice had chewed through one of the spark plug wires.  currently have a substitute hooking the chewed end to the ignition coil so itll run on both cylinders however im having an issue finding a replacement coil wire for it and was wondering if yall had any advice.  i need the longer of the two coil wires and i can only find the shorter one online.  will throw up some pics of it when i can
    • By Jeff Cotter
      I recently purchased a 2000 polaris xplorer 400 4x4.  When I bought it the starter was bad, speedometer didn't work,  and it had been sitting for 5 years. I replaced the battery, and starter. Changed all fluids, and got it running correctly.  Then replaced the speedometer in an attempt to make sure the awd would be available when needed.  And took it out for a couple hour ride with a buddy.  
      It ran great that ride with no serious problems just a little carb issues which I was able to take care of on the trails.  Then a couple days later I decided to take it out for a ride by myself,  again ran great no issues other than a couple times it seemed to cough and then take off again.  That day when I was loading it I noticed coolant dripping onto the trailer and the overflow bottle was empty.  
      Got home and decided to drain the counter balancer, when I did that I got about 3 cups of coolant. Im guessing that it needs new seals and all for the water pump.
      My question is how difficult is it to do the water pump and should I attempt it or should I send it down the road to the polaris dealership to get it done? 
       
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...