Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Gunny

3 Days Of Rid'in . . .

Recommended Posts

Here's a short video of 3 different days of some of my spring & early summer riding. Hope you enjoy it. :yes:

 

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Ed Zeppeli
      So I fired up the quad the other day and let it idle for about 5-10 minutes and it ran great then died.
       
      I go to check it. No lights on dash, nothing.
       
      Check the main fuse and it's blown. Key's off/out. Put in another and it blows immediately.
      Pull out the meter and see that on the non-load side of the fuse holder there's continuity to ground.
      Check all obvious things. Wiring diagram. Connectors. Frayed wires. Bad grounds.
      Battery measures ok at 12.8v.
      I'm dreading taking off the front plastics but I suspect the regulator/rectifier. The wiring diagram shows the red wire (the suspect wire) goes to the ignition switch and the regulator/rectifier.
      Anyone else experience something similar and/or have any troubleshooting tips that may save me the grief of removing the plastics?
       
      Thanks much,
       
      Warren
    • By ATVNetwork
      This past weekend the 2019 ATV Motocross Championship (ATVMX) Series, an AMA National Championship, took over Loretta Lynn Ranch in Hurricane Mills, Tennessee. Hot and humid conditions greeted the AMA Pro ATV athletes, and the cloud coverage that graced the facility seemed to disperse as the riders lined the gate for moto one. Eighteen riders took to the gate for the penultimate round of racing. 
      View the full article
    • By mikeexplorer
      Actually have a long weekend off, usually we work the holidays but the plant shut down to install a new switchgear so lucky me! Took a ride on an old railroad grade that is now a recreational trail and legal to ride. There are a few places to stop and get something to eat. Michelle is driving her old quad, a 2010 366 which I kept as a backup machine. Her Alterra developed a hard starting problem at Snow Shoe, so it will be off to the dealer to adjust the valves. Was good to give this machine a nice long cruise run as it doesn't see many miles anymore.
       







    • By Ryan Lewis
      Went on a great ride on Sunday from the M-33 trail head to the Lupton trailhead in the Huron National Forest.

      More videos from the ride to be uploaded to the channel soon.
       
    • By johncb
      Looking for some answers, my brothers 06 outlander max xt 400 once in a while gets jerky when riding it. Does anyone have any ideas what to start looking at first.
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...