Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

jim estes

Yamaha Terra Pro YFP350 Lock Into Reverse

Recommended Posts

Just got a Terrapro, almost by accident. Does anyone know why it wont lock into reverse? I know reverse works because I can hand shift at the tranny. Its almost got to be in the linkage...any idea? 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Tagged Content

    • By JacobSlabach
      Hey so i sold my 04 rubicon and wanted something new so i went to NC and bought a '13 scrambler 850XP LE EPS.  love it the only issues with it when i bought it were a leak in the front tire and the mice had chewed through one of the spark plug wires.  currently have a substitute hooking the chewed end to the ignition coil so itll run on both cylinders however im having an issue finding a replacement coil wire for it and was wondering if yall had any advice.  i need the longer of the two coil wires and i can only find the shorter one online.  will throw up some pics of it when i can
    • By Lank Firdmont
      I have seen other posts and I'm not ableto download resources.
      I was gifted a Yamaha TerraPro and can find 0 online for help getting this running.
    • By wHarmon
      Our 1988 Yamaha Terra Pro is finally seeing the finish line of becoming our new bush hogging tractor! I've had the terra pro for almost 2 years... we had great intentions, but after removing the fenders, fuel tank, and the carb, we let it sit up. Shame on us! However, the terra pro is cranking today. We cleaned the carb, figured out what goes where and where did that screw go! She smokes like there's no tomorrow, but that's okay! The only issue right now is getting all these lines hooked back up to the carb right! There is 5 lines to hook up to this thing!! And in our moment of drinking and removing parts, we cant remember how they go back on. I've found several diagrams online, but none showing the overall schematics of all the lines! If anyone has a service manual, or any way of helping us figure out what goes where I would really appreciate it!! I can attach pictures later if it'll help!
  • Similar Topics

    • By Old_ATV
      I have a mid 2000 sportsman 700 that only works in low gear.  Any thoughts?
    • By donerightautomotive84
      Ok so 2000 sportsman new.caltric carb new fuel pump new jug and piston new cdi and coil finally get to start it and itll idep for 5 to 10 seconds and die what am i missing people any help id love ya forever lol
      Sent from my LM-Q720 using Tapatalk
    • By richard fischer
      I have a new 2020 cforce 600 touring and read how smooth the shifting was on it. Mine however, sticks in gear quite often and only after moving the bike around does it finally shift. I use the brakes before shifting as it says but that doesn't seem to affect it either way. Anyone have this issue? Is there an adjustment on the linkage perhaps? Any suggestions are appreciated. The machine is new with about 10 miles on it.
    • By Gsk1500
      My byou finally got running after I rebuilt the carb. I took it for a trail ride, and finished by riding her pretty hard up a dirt hill. At the peak of the hill it dropped out of gear, and had to be pushed home. It will still start, and idle. When I apply throttle it revs really high, and no matter what gear it is put into, it will rev high and take a few moments after i release the throttle to wine down.

      I have pulled the clutches out, and it does appear the centrifugal clutch is worn. I took the dremel to it, and tried to get some relief lines back in there.

      Before I reassemble and test, does anyone know if this is even a clutch issue? or possibly transmission/case related.
      also can I make a gasket out of cardboard and Indian head just to test after  cutting grooves in centrifugal clutch?
    • By gareth leifheit
      Ive got a Big Bear 350 4x4 that has been sitting for a couple years. It was put away running but now the pull start wont move and the starter wont turn it either. Any ideas what I can lube up or bang around to loosen it up? Thanks
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...