Quantcast
Jump to content

  • Do you own an ATV or UTV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Preferred carb kit brand?


Recommended Posts

  • 1 month later...


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By BuckBilly
      Good morning to all !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
      Let's see if we can make this a daily event.
    • By chimmike
      Picked up a 98 Quadrunner 500 for a song. It's in rough shape, but funny enough it turned over and fired on starter fluid. Fuel lines are rotted to snot and the inlet tubes to the carb are rusty. I have a rebuild kit for the mikuni, but I'm wondering if anyone has used any of those alternatives on Ebay or Amazon that say they fit? 
    • By Travis Waller
      We just bought this about 2 weeks ago and the chain keeps popping off. I’ve dealt with 4 wheelers in the past but nothing with this chain setup.



    • By Brent Wright
      What's a good size to start a 10 year old on?
    • By AKMichael
      Hello All,
      I have a 1999 Yamaha Big Bear 350 4x4 trying to get fixed up so my grandson can go out in the woods with me.
      We have owned it over 10 years.  It got harder to start, until it finally would not.  Replaced the carb.  Right afterwards, it started and ran nicely, but after turning it off, would not restart.  Tonight I used starting fluid and ran, then died.  Adjusted the idle up a little, used more starting fluid and ran great.  It idled about 15 minutes.  Turned it off, and restarted.  Ran it around the yard about 5 minutes.  Turned it off, and would not restart.
      Any ideas or suggestions would be greatly appreciated!
      Thank you. 
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...