Quantcast
Jump to content

  • Do you own an ATV or UTV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

New member with kymco MXU 500i dx


Recommended Posts



Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By Abbeypalm
      While cruising, my 2011 750 king quad suddenly shut down. As it happened, red lights on the display flashed. Any ideas? My head lights suddenly stopped working about a week ago, if that helps. I have no power at all. Thanks 
    • By technofarmer
      Hey there, i have recently put a new drive belt on my 11 Polaris Sportsman 500 H.O.    It has 44 miles since putting the new belt on and should be nearly broken in as i hear it takes 50 miles to do so?  Anyhow it has had a little trouble with slipping since i put the new one on a few months ago. Now whenver i go down a hill the belt seems to be getting caught in one clutch if not both and then it has to run a high rpm just to go a low speed.  Today it did that again going down hill, i stopped, put it in neutral and when going back up the hill i had to turn it off, put it in neutral, let it roll back down the hill a little, then restart it, low range and it was slipping but thankfully i was able to make it up the hill. 
       
       So what might the problem be? Is this a need for another new belt? New clutches and belt? Or just get something else? BTW the brand new belt i put on it, is a factory one, an exact replacement for the original.   

    • By oxidized_black
      View File 2006 - 2011 Honda TRX 250EX Service Manual
      5851e0ba82762_2006-2011HondaTRX250exServiceManual.pdf
      Submitter oxidized_black Submitted 12/14/2016 Category Honda ATV  
    • By bodon
      Anyone know what the fuse terminal marked UNSWITCH  does  .  Even with the key off it is causing a drain on my battery and I'm trying to figure out  what that terminal goes to.  It's a 10 amp fuse. If I pull it the "short" goes away.  Thanks in advance.
    • By schwartz10
      2011 Brute Force 750 I. Having an overheating issue. When fan sensor is unplugged by thermostat fan will run and cycle. When its unplugged it will not run and cycle. Need help. Really dont want to take to dealership.
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...