Quantcast
Jump to content

  • Do you own an ATV or UTV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

2012 big bear oil change


Recommended Posts

I don't have a manual and want to do an oil change. What is the recommended oil. Are these wet clutch? Can I use synthetic? Kinda at a loss for what to buy. Obviously oil changes aren't that expensive so not afraid to buy a good quality oil. 

Edited by Samwise
Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Tagged Content

  • Similar Topics

    • By BuckBilly
      Good morning to all !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
      Let's see if we can make this a daily event.
    • By Sandbox
      What all is included in the normal maintenance service of the Polaris ranger 1000 Xp ? My neighbor wants to service his machine and says he has a “kit” for it , oil change. Are there any hidden grease fittings? Pitfalls?
       
    • By Brent Wright
      What's a good size to start a 10 year old on?
    • By buzzar56
      I am looking for a free repair manual for a 2003 Polaris sportsman 500 ho atv. all the posts on here lead me noplace
      thanks fred.
    • By ENG243
      Hello 
      I have a 1994 Kawi Bayou 400 which had been running well until it sat for about a month. I left the carb dry while it was park and the temp had dropped below 0C in this time. Pulled it out last night to go for a ride and it fired up just like it should but noticed when I started to head down the road I could hold it to the bar and it didn't seem to accelerate. Lower gears weren't as noticeable but 4th and 5th it just seemed to have no acceleration and half or full throttle  made no difference. if I tried to go into 5th gear with any throttle it would stall. I turned around and just poked home very slow and it seemed to stay running but this was between 15 and 20 km/h max. 
      I have taken the carb apart and it appears to be clean and nothing stood out on inspection to have dirt or ice. Is there something I should dig more into? 
      I have checked the plug and it appears to be sooty with easily rubbed off carbon. I plan to get a new plug today and test. 
      compression with the throttle wide open is 175 psi. 
      I have opened the drain plug in the exhaust thinking there could be a mouse in the exhaust or something but no difference. 
      I do find the engine is tickity compared to my 2000 Honda but I am not sure if this is just me looking for issues or if it has always been this way. 
      If anyone has any insight I would appreciate it.
      In the last 6 months I have done new oil and filter ( mystik synthetic) 
      new Peak RPM CDI 
      I have noticed the fan comes on more often with the new CDI, could this be a program thing?
       
      Mike
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...