Quantcast
Jump to content

  • Do you own an ATV or UTV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

2017 Sportsman 570 Valve adjustment


Recommended Posts



Intake valves: .006 +/- .002 in (.152 +/- .050 mm)

Exhaust valves: .008 +/- .002 in (.203 +/- .050 mm)

They are shim under bucket, so if they need to be adjusted it would be wise to measure all of them and adjust all at the same time. All 2017-2020 Sportsman 570’s are the same. 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Tagged Content

    • By jung4g
      The quad has done this off and on, almost since new, but it's gotten worse this year. Sometimes if I freshly charge the battery, it'll work fine, others times that won't matter. Turning the key to on it sounds like it's connecting as I go to the start position, slightly before the full turn, but it's not like there is just a sweet spot to find, it's totally erratic.
      Now the battery is basically dead so I put a new, slightly bigger AGM battery in today to replace the factory one with all of 800 miles on it, but those have lots of plowing hours included. 
      I was able to get it started once, but it still went into limp mode after just a few moments of driving it (that's another topic), so I put it back in the garage and started probing around. Now it doesn't even try to turn over.
      Is an ignition switch, the $18 shipped aftermarket variety on Amazon worth a shot? Or should I go straight for the starter? The new switch may not come for over a week, so I hate to just put my hopes in that if I'm missing something obvious. Fuses are good, so it's not something super obvious.
    • By Mark Gibeault
      Does the onboard system provide everything needed to atleast point out any electrical component malfunction and is there ang benefit of using an obdll diagnostic tool with an adapter for this machines diagnostic port?
    • By jwline
      Friday evening went riding, rode for a good hour or so everything was fine. I went to take a short ride to the restroom (less than 100 yds away) and all of the sudden everything flickered and then just died out. Accompanying the problem I noticed the killswitch completely locked up. Once daylight hit took the killswitch apart to find it had shorted out and melted the plastic inside. Has anyone else had anything similar to this and if so what did you do to fix the situation? I have a new killswitch on the way to replace the obvious problem but was wondering could there be a bigger issue at hand. We tested with a voltage meter to make sure everything was still getting power from the battery and as far as we could tell it was.
      Any advice/info would be GREATLY appreciated.
      Thanks.
    • By Budman
      After purchasing a lightly used 2018 570SP (300 miles on it) I noticed that the display was flashing on and off. I remember reading awhile back that this was a common problem on the 18 model. I can't remember what the fix is. It also turns over slow even though the battery is charged. Anybody know what the fix is on this issue?
      Thanks
      Budman
    • By Jeremy Morris
      If you're getting that pesky leaky seal on the pinion of your front differential and the pinion has allot of play, polaris won't sell the bushing needed to repair it properly without having to shell out big bucks for the complete ring and pinion kit. 
      I have a kit with an upgraded bushing, Japanese made bearing and USmade seal
      50 shipped in the US and 55 to Canada

  • Similar Topics

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...