Quantcast
Jump to content

  • Do you own an ATV or UTV? Join our Forum!

    Join QUADCRAZY ATV Forum today for FREE! We keep these forums clean and user friendly. All first posters will have to wait to have their content reviewed and approved. Once your first post is approved, you will no longer need to got through an approval process. To gain immediate approval and a NO ADS experience, consider subsribing to our Premium Membership.

Linhai Bighorn 28 (400) Stalls when accelerated


Go to solution Solved by drjulian,

Recommended Posts

Linhai Bighorn 28 (400)

Starts ok and idles, however when I start to accelerate, it will accelerate for a few seconds then dies as if it has run out of fuel. I can keep it going by pulling the choke out while accelerating and driving by using the pedal and the choke at the same time adjusting both to keep it moving. When I stop accelerating, it will idle indefinitely without stalling.

Full tank of gas.

Any advice on what could be wrong and what I should be checking?

Thank you

Link to comment
Share on other sites

Could be a blocked fuel filter, a bad pump if it has one, dirt or water in the carby.. Easiest is to check there is a good supply of fuel getting to the carby.  If it has a drain screw on the bottom of the carb I'd undo that with the fuel tap off and catch the fuel as it drains to check it for water. Then I'd leave the drain open and turn the fuel on and make sure it flows out again at a reasonable trickle. If it doesn't have a drain screw, I'd pull the fuel hose off the carby and check for a good flow of fuel there.

If there's plenty of fuel getting to the carby, I'd pull the carby and clean it..

Link to comment
Share on other sites

If you tell us how many seconds, with what amount of throttle, we can probably guess where a fuel blockage would be.

Best if you time it with about a quarter throttle, and then again at about three-quarter throttle.. 

Ha.. ok.. you were too quick for me.

Well done on the repair.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Similar Topics

    • By olddude
      When I bought this ATV I noticed a slight miss between mid and high speed. Now I notice it has developed a bad cough as well as the miss. At first it was mainly when you first started, the cough that is, now even after the bike is warm. I also notice that I have an exhaust leak right behind the motor is it possible the leak and cough are related? I haven't pulled any of the plastic off yet I was just wondering what to look for once I do as it will be a big pain when I do.
    • By QuadRunner
      I'm hoping someone can help me diagnose my 2008 King Quad 450 no start
      A couple days ago, after running for a few hours at low speeds (2-3mph wiping weeds), seat got hot, motor started to stumble, and we turned it off. Gave it a few minutes to cool down, turned on key, dash flickered, then lit up, I tried to start, but it did not turn over, dash died like the battery was dead.
      Quad acted like it was overheated, but I noticed a lot of heat coming from battery area. Checked battery voltage, showing 10.5 volts. 
      I had something similar happen last year, and it ended up being the regulator/rectifier. It killed the battery that time too.
      So, this time I pulled the battery, it stayed quite warm for over an hour. Put it on trickle overnight. Next day it showed over 12 volts. Took it to advance auto and had it tested. Bad cell. Bought new battery.
      Installed new battery. Now when trying to start, it seems normal, turns over, and begins to start, but immediately dies.
      I have ordered a new regulator/rectifier that will get here tomorrow. But today, I pulled the regulator and tested it according to the service manual. Ran a diode test using my multi-meter between all the pins on the regulator. They were all within range according to the service manual.
      Unplugged stator, and tested it. Showing 1.9 ohms between all pins. This is out of range. Should be .1-1.0 according to manual. However, I have a brand new spare stator, and that one also reads 1.9 ohms. I'm guessing my multi-meter is the problem?
      Used a paper clip to jump pins and put the dash into "dealer mode". Shows C00. No codes.
      Last time the regulator failed, I was able to remove the negative battery cable and do a leak test with the multi-meter. I observed a voltage leak, and when I unplugged the regulator, it would stop leaking. This made it clear to me that the regulator was the problem. This time, no voltage leak. Also, last time the regulator failed, it would still run fine with a new battery, it just wouldn't charge. Now it won't stay running for more than a second. I'm thinking this could be something else. Any ideas?
       
    • By oxidized_black
      these are what i have in my collection ... always looking for more
      1999 - 2004 Can-Am All Line service manual
      http://rapidshare.com/files/4269188252/1999%20-%202004%20Can-Am%20All%20Line%20Service%20Manual.zip
      2003 Can-Am Rally 200 service manual
      http://rapidshare.com/files/1466175272/2003%20Can-Am%20Rally%20200%20Service%20Manual.zip
      2006 Can-Am Bombardier Outlander Series 400 & 800 Shop Manual
      http://rapidshare.com/files/1526634762/2006%20Can-Am%20%20Bombardier%20Outlander%20Series%20400%20%26%20800%20Shop%20Manual.pdf
      2006 Can-Am 400 & 800 Outlander service manual
      http://rapidshare.com/files/906874897/2006%20Can-Am%20400%20%26%20800%20Outlander%20Service%20Manual.pdf
      2006 Can-Am 400 ATV Motor Shop Manual
      http://rapidshare.com/files/1087506035/2006%20Can-Am%20400%20ATV%20Motor%20Shop%20Manual.pdf
      2006 Can-Am 800 ATV Motor Shop Manual
      http://rapidshare.com/files/3209628612/2006%20Can-Am%20800%20ATV%20Motor%20Shop%20Manual.pdf
      2007 - 2008 Can-Am Renegade 500 & 800 / Outlander 500-650-800 service manual
      http://rapidshare.com/files/2295042057/2007%20-%202008%20Can-Am%20Renegade%20500-800~Outlander%20500-650-800%20Service%20Manual.pdf
      2008 Can-Am DS450 Shop Manual
      http://rapidshare.com/files/938708221/2008%20Can-Am%20DS450%20Shop%20Manual.pdf
      DS450X Specs
      http://rapidshare.com/files/1642152510/DS450X%20Specs.pdf
    • By SDK777
      Does anyone use a fuel additive in their quads? If so, what are you using?

    • eManualonline.com Save 20% OFF on orders over $50, Use Code: BLAZE


      eManualonline.com Save 20% OFF on orders over $50, Use Code: BLAZE


      eManualonline.com Save 20% OFF on orders over $50, Use Code: BLAZE

    • By TSWIII
      I let my ArticCat sit over the winter but before it was put in the garage it was running perfect. In taking it out this year it wouldn't start. I can start it with a charger and it will idle just fine. But it's doing something weird now. Either the display 1)won't display anything or 2) it will just display the analog speedometer but none of the digital stuff or 3) it will display all. So it was acting really sluggish when in HIGH gear and sounded like it was in low gear. So in driving it down the road and it being sluggish, I switched the ignition key to "Lights ON" and the ATV immediately picked up as though it really was in HIGH gear. Switching the ignition back to "ON" was like down shifting into LOW gear. When I came to a stop and switched from LIGHTS on to just ON the ATV completely died. After a 30 minute ride you would think it would start again but I had to jump it again to get it to start. Same issues with the ignition having to be pointed to Lights for it to run decently. Then just as I got back to home base the display showed VOLT. It acts like it's something in the ignition but not sure how that's related to the gears. I put a gas cleaner in the tank since it's been sitting but it really doesn't seem like a bad gas issue that I thought it was at first. I checked the IGN fuse but it seems fine, replaced it with the extra fuse but no joy. Anyone have any ideas?? Thanks in advanced for any help. It's much appreciated. 
  • Similar Tagged Content

  • Gallery Images

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...