Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

turbolag

new to forum king quad 300 k1?k2?

Recommended Posts

hi the this is my first post i just picked up a used 2001 kingquad 300f great little rig unfortunately the front right cv axle is a little bent so it needs replacing and all the part sites ive looked at ask if it is an X z or a k1/k2 so im wondering how i find that out?

also do you recomend any place that will stock that part and ship to the west coast of canada

any help would be great thanks.

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Arizona
      So few months ago I acquired a 01 Explorer 4x4 (think its a 350 but not sure) 
      Anyway the owner said it started reving very high, shut the key off and still kept running 
      until finally he shut off fuel and it finally died. During the run away he said the exhaust got 
      red hot and has melted plastics to prove it. Said some thing flew out the tail pipe, I kinda figured
      it was the top of the piston. Anyway finally got around to looking at it (have a lot of other projects in the works)
      and checked the compression, Shows about 40 psi. Can hear air coming out the carb while rotating the motor over. 
      Gonna pull it apart eventually, don't hear any noises or binding in the stroke, You think the piston came apart? 
      any horror stories of these and is it worth my effort and money? Don't really have any money in it yet. Thoughts? Az


    • By Cj Winds
      I have a 2000 Polaris Xplorer with the 250 two stroke motor
      It does not want to start with the electric start, the motor cranks fast, the battery is good, and there is good spark when cranking. The engine starts perfect when using the pull cord, it even starts if I pull the cord slowly and starts with one pull. The engine idles smoothly once started. My wife says she needs the electric start to work.
       
    • By mrfartsalot
      I have a 2001 suzuki quadmaster 500 4x4 automatic and i was wondering witch atvs it shares parts with i know it shares some with artic cat. Any info would be helpful.



    • By Chase Cook
      I have a Yamaha warrior 350 and it has a brand new head and piston set. The piston has some scoring on the sides so I bought a new piston kit and it should be here tomorrow. The bottom of the cylinder head still has the cross haching on it but the mod and top don't and still looks good. Do I have to rehone it or no? No would be a great answer LOL.. need help. Also if I do is there another way to rehone it without a honing tool.. don't have one..
    • By Tracy Flickinger Vargo
      Hi.  New to all of this.   13 year old Son bought a 2013 TaoTao ata -150c quad that needs a new harness and stater.  Tao Tao said they discontinued the model and making replacement parts.  Help?!?   Anyone know where to find these parts?   
  • Similar Tagged Content

    • By Ashton Crawford
      Hello everyone, i have 2000 Polaris Trail Blazer 300 I’ve been stumped on for weeks. I’m having a lot of issues starting the quad. I cleaned the carb spotless because I thought it was a carb issue and bought a new fuel line because it wasn’t getting fuel. The carb gets fuel perfectly fine now but it won’t start. The spark plug I a little worn out but it’s good enough for just one start. The only time it does “start” is when I spray starter fluid into the carb. But it never stays on. It’ll start for a bout a second then just die out immediately even if you’re giving it some throttle and the choke is on. I have no clue what I should do. If you need more information, have questions, or have any slight idea what the issue would be and how I could resolve it. Please reply ASAP. Thank you.
    • By Alan Callison
      OK ya'll.My son bought this thing and was told its a Kaw Bayou 300. Maybe. I cant find any numbers on it.The one tag I did find its so faded as to be unreadable. Its a long shot but maybe someone can help ID it. Thanks in advance.









    • By Jeff Wharton
      I have a 2000 Arctic Cat 300 4 wheeler. I have been having some carburetor issues. So i bought a new carb. Now I'm having these issues. The unit will start and idle fine, when i go to accelerate it wants to cut off. So i checked to make sure it was getting gas and the fuel filter will be full of gas and then once the carb opens the filter drains down and will not refill quick enough to run. So i checked to make sure gas was flowing to the filter and it is flowing fine through the line. I remove the filter and run the gas line directly to the carb and the engine idle fine and then it will run good as i ride it for about 10 minutes then it will start with the same issues again i cannot accelerate enough to move the 4 wheeler. Every time i accelerate the unit will cut off. What is wrong with this thing. My 400 Arctic Cat is doing the same thing except it will backfire, I'm lost i have tried everything i know to do, what am i missing here. Thanks for your help
    • By Maurais
      I’m looking for new replacement shocks (front & rear.) on my 1997 Kawasaki Bayou 300 2x4. New OEM shocks are upwards of $400. I haven’t pulled the rims off to check the eyelet to eyelet length but I’m hoping an expert on this site does know( I called Kawasaki direct yesterday and they were of know help.) Any technical help would be appreciated. TY fellow members. Vic
    • By scottj11
      Hello, how are you'ns doing? I'm in the process of tearing my Kawasaki Bayou down to fix a rattling noise and an oil leak. I'll probably be asking questions about this project. My step-son has an Arctic Cat 300, he was riding yesterday and when he turned it off it was running fine, but it won't do anything. The lights come on but it won't turn over or anything. Does anyone have any ideas on what might be wrong? TIA
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...