Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

turbolag

new to forum king quad 300 k1?k2?

Recommended Posts

hi the this is my first post i just picked up a used 2001 kingquad 300f great little rig unfortunately the front right cv axle is a little bent so it needs replacing and all the part sites ive looked at ask if it is an X z or a k1/k2 so im wondering how i find that out?

also do you recomend any place that will stock that part and ship to the west coast of canada

any help would be great thanks.

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Tagged Content

    • By Curtis01
      OK, sooo  I finally did the old skid plate and screen removal to clean out my oil sump during an oil change...  This bike only has a couple thousand miles on it.  Runs like a top still...  Very few issues over the years after buying it used.
      But boy I wasn't expecting to see this!  Piece of a circlip, stuck up in the screen, and a another shard of metal and maybe a piece of gasket material.  Nothing in the oil but that...  Pristine otherwise, and still runs like a top.  Always has.
      Soooo, is it a wrist pin clip?  That's the only thing I can think of like this that could end up in there.  But definitely wanted to throw it out to guys that have seen the innerds of these more than I have.
      The valves on this thing are still within the factory spec even.  Been a really good lil workhorse...
      Any other ideas?

    • By Guythis448
      Looking for help on wiring up stock wiring harness specifically for a '88 Honda TRX 300 
      If anyone could drop a link or send me a PM it would be much appreciated 
    • By Ashton Crawford
      Hello everyone, i have 2000 Polaris Trail Blazer 300 I’ve been stumped on for weeks. I’m having a lot of issues starting the quad. I cleaned the carb spotless because I thought it was a carb issue and bought a new fuel line because it wasn’t getting fuel. The carb gets fuel perfectly fine now but it won’t start. The spark plug I a little worn out but it’s good enough for just one start. The only time it does “start” is when I spray starter fluid into the carb. But it never stays on. It’ll start for a bout a second then just die out immediately even if you’re giving it some throttle and the choke is on. I have no clue what I should do. If you need more information, have questions, or have any slight idea what the issue would be and how I could resolve it. Please reply ASAP. Thank you.
    • By Alan Callison
      OK ya'll.My son bought this thing and was told its a Kaw Bayou 300. Maybe. I cant find any numbers on it.The one tag I did find its so faded as to be unreadable. Its a long shot but maybe someone can help ID it. Thanks in advance.









    • By Jeff Wharton
      I have a 2000 Arctic Cat 300 4 wheeler. I have been having some carburetor issues. So i bought a new carb. Now I'm having these issues. The unit will start and idle fine, when i go to accelerate it wants to cut off. So i checked to make sure it was getting gas and the fuel filter will be full of gas and then once the carb opens the filter drains down and will not refill quick enough to run. So i checked to make sure gas was flowing to the filter and it is flowing fine through the line. I remove the filter and run the gas line directly to the carb and the engine idle fine and then it will run good as i ride it for about 10 minutes then it will start with the same issues again i cannot accelerate enough to move the 4 wheeler. Every time i accelerate the unit will cut off. What is wrong with this thing. My 400 Arctic Cat is doing the same thing except it will backfire, I'm lost i have tried everything i know to do, what am i missing here. Thanks for your help
  • Similar Topics

    • By cfauvel
      ok help so according the service manual, Idle Air Mix Screw (aka Pilot screw) should be initially set to 2.5 turns out from fully seated.

      If I do that the motor doesn't want to start or stay running...right now the pilot screw is probably somewhere near 5 turns out....I'll take the carb off tomorrow to count to know for sure.

      mind you the carb got a new float seat,float needle and various other components in the kit.

      To get the motor running I hard to turn the pilot screw out quite a bit, and turned the idle speed screw in quite a bit...I didn't hook up an inductive tach to know what it is idling at, but does sound about right.

      What should the idle speed adjustment screw initially be set at (the one that has the black cable sheath with a knob you can twist easily)?

      Is there a special tool to turn the idle/pilot mix screw whilst the carb is on the running motor? I am using a slotted screw driver bit (normally goes into a driver) by hand..makes it hard to turn the driver and hard to tell how many turns .
    • By Bryzan3
      Looking for advice on what to try next I bought this quad and it’s has spark and fuel but won’t stay running only fires when I hold the starter button in even when spraying gas into the carb it still dies right away oil was milky white so I was thinking it maybe went under water 150 psi compression so I might be wrong but not a head gasket I am stuck Cause it should stay running with the straight gas through the carb so what should I try 
    • By Curtis01
      OK, sooo  I finally did the old skid plate and screen removal to clean out my oil sump during an oil change...  This bike only has a couple thousand miles on it.  Runs like a top still...  Very few issues over the years after buying it used.
      But boy I wasn't expecting to see this!  Piece of a circlip, stuck up in the screen, and a another shard of metal and maybe a piece of gasket material.  Nothing in the oil but that...  Pristine otherwise, and still runs like a top.  Always has.
      Soooo, is it a wrist pin clip?  That's the only thing I can think of like this that could end up in there.  But definitely wanted to throw it out to guys that have seen the innerds of these more than I have.
      The valves on this thing are still within the factory spec even.  Been a really good lil workhorse...
      Any other ideas?

    • By Michael Thornton
      Why does the 2001 grizzly not have com bearings or something to protect the head.
    • By ATVNetwork
      news The KingQuad 500 and 750 Power Steering models get plastic utility rack covers.
      Suzuki says the snug-fitting covers can aid load securing or be a workstation. View the full article
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...