Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Sign in to follow this  
quadcrazy

2009 POLARIS RANGER RZR 800 EFI 4X4 (Benton, KY)

Recommended Posts

(This Ad is from QUADCRAZY Classifeds, click "More" to find out how to contact the person who placed this ad.)

2009 POLARIS RANGER RZR 800 EFI 4X4 with only 651 miles on it. It is a 800 CC 4 STROKE EFI ( FUEL INJECTED), FULLY AUTOMATIC WITH HIGH, LOW AND REVERSE,ELECTRIC START. IT IS A 4X4 RZR WITH 4X4 & 2X4 SWITCH. THE BRAKES ARE GOOD FRONT AND REAR. THE BOD...

More...

Share this post


Link to post
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Forum Topics

    • 2004 Polaris Sportsman 500 Reversed Terminals On Battery

      Got a 04 Sportsman 500 that wasnt running- owner said it needed a stater and a new battery.  It ran rough (been sitting out in the weather for a while).  A friend and I started by adding a new battery and it would start barely with the choke and his hand over the air-filter.  I decided to install the new battery in the holder on the side.  we had it on the rack because the old on was still in the bike.  I tried to be nifty by turning the battery to put the terminals in an easier spot to get to, but forgot to reverse the cables too.  In a sentence, I reversed the positive and negative on the battery like a dummy.  When we discovered my mistake and corrected it, we turned on the bike, but the display did not light up and the key did not turn on the starter.  jumping the solenoid worked the starter, so we thought the solenoid just burned up when I reversed the pos and neg...  new solenoid and no difference.  what have I burned up?  Also, the shifter does not seem to do anything in the trans.  it slides back and forth like its stripped in the trans.  any help would be appreciated!! I think the biggest issue right now is the electrical.

      By JacobSlabach, in Polaris ATV Forum

        
      • 7 replies
      • 54 views
    • Rebuilding 2002 Suzuki Quad Master 50 2-stroke

      Hey everyone,been dealing with quads since I was a kid,now I have a son who loves my raptor 700 and had gotten him an electric power wheel quad but it didn’t cut it for him.so for his birthday “xmas eve” I picked up a used 2002 quadmaster 50 for 500 bucks. It started and moved but needed work.. got it home drove it for a few feet and it started bogging down and would shut off. so I stripped quad down to the frame cleaned it up as best I could without removing motor from frame. replaced top end new head piston rings etc cheap kit off eBay along with carb that will be here today.the filter that was on carb was degraded and soaked with gas. Also new cylinder doesn’t have vacuum line so how do I block that off without getting new petcock valve? tightened chain. guy said quad doesn’t take oil as it’s a closed case right then I knew the guy knew nothing about the machine. So I changed oil,was black and thick and just nasty like sludge. suspension in rear seems good but the fronts are very stiff,any way to adjust these or should I get a new set? also upon stripping everything down I noticed the exhaust restrictor was gone so without that do I need to update jets in new carb,old carb has original jets?? and also I’m new to cvt tranny so how would I know if it’s bad etc? sorry for all the questions just want to make this thing safe for my 5 year old knucklehead. added some photos of my current progress didn’t take any inbetween cleaning everything though    please any info will be appreciated. i haven’t rebuilt a quad since 1999 when I had my blaster and my buddies had other 2 strokes I was the mechanic with no knowledge but always seemed to get things right!! also if you notice the old head looked chipped and damaged and I’m wondering if those chips made it into motor how would I go about finding them?i would think by now they would be chewed up? I did not strain oil that I drained but might do that later when the kids are sleeping and I have time to check it without kiddo seeing!

      By Jhyman1984, in Suzuki ATV Forum

        
      • 1 reply
      • 45 views
    • 2007 Polaris Hawkeye 300 Clutch Slipping?

      My Hawkeye runs great just wont pull could this be the breaking clutch or the drive clutch thanks for any help

      By Steve Howard, in Polaris ATV Forum

        
      • 9 replies
      • 205 views
    • Polaris Sportsman 450 headlight mod

      I am trying to figure out a way to make my high beam include the 2 front lights that come on in low beam mode. As it sits now I need to use the low beam to see the trail in front of me but can't see far ahead. On high beam I can see ahead but miss most of the trail right in front of me. Does anyone know of a kit that would mate the two front lights to the main headlight on high beam ? 

      By kgard, in Polaris ATV Forum

      • 6 replies
      • 49 views
    • 2004 Polaris 700 headgasket repair

      I will be posting some updates on my head gasket repair on a Polaris 700 sportsman. Hopefully this will help some of you guys with you own repair.

      By Kenneth Obando, in Polaris ATV Forum

      • 7 replies
      • 43 views
  • Recently Browsing   0 members

    No registered users viewing this page.


×