Quantcast
Jump to content

  • Do you own an ATV or UTV? Join our Forum!

    Join QUADCRAZY ATV Forum today for FREE! We keep these forums clean and user friendly. All first posters will have to wait to have their content reviewed and approved. Once your first post is approved, you will no longer need to got through an approval process. To gain immediate approval and a NO ADS experience, consider subsribing to our Premium Membership.

Welcome to QUADCRAZY!


quadcrazy

Recommended Posts

If you are a new member, why not introduce yourself? This community thrives and grows with you and all our current members! We all want this community to grow and encourage new member registrations. That being said please help out QuadCRAZY by inviting other atv'ers to the community.

QUADCRAZY NEEDS YOU!

  • Like 8
  • Thanks 1
Link to comment
Share on other sites

  • 4 months later...
Guest Fox300exchic
Hi,

New to the site so I thought I would drop in and say hello!!! Love the site so far, can't wait to talk to some new people. Really want to hear from the other ladies who are just getting into this like I am!!! Love to hear from those of you with experience as well!!! ;)

There is an area for the ladies here in the forums called She Rides. Feel free to drop by.

Link to comment
Share on other sites

  • 2 months later...
Guest wesche1

Well I finally got back on after my initial visit to the site seems a little hard to figure out where everything is but I'll get it. anybody else on this site from MD or close to it I also have family in KY so maybe we can hook up & go ridin sometime. I just bought a 2007 kingquad 700 after cracking the crankcase on my vinson so I'm starting the building process all over again. If anyone hears that the vdi is out for my bike please let me know.

Link to comment
Share on other sites

  • 5 months later...
Welcome Stoopidbot1! You've got some great pictures! I highly suggest everyone else check them out: http://www.quadcrazy.com/user/Stoopidbot1/gallery

How's it going over there at ATVFan?

ATVFAN is just like this one, a bunch of cool people who all have a common interest. Thank you very much for the compliment on the pics. My wife and my best friend are some amazing photographers. They just pic a good spot on the side of the track or trail and I do my thing. So actually they thank you. LOL I look foward to meeting new people. I'll post some more pics. By the way, I love the monthly contest!

Link to comment
Share on other sites

  • 2 months later...

hi all im keith and my son is joshua he bought a kawasaki ksf 250 the other night and we are new to this as neither of us have ever had a atv before and so are having trouble starting it it has been in storage for about a year now and yesterday we changed the oil and put fresh gas in (it was stored without gas) and so just cant get it started now my cousin says it needs the catb rebuilt is this something we need to look at ? any help would be very usefull thanks keith

Link to comment
Share on other sites

  • 1 month later...

Hey i know this is a little late for this thread, but i'm new, Stoopidbot invited me here from Atvfan, just wanted to say hey cause i don't know anyone. But i'm having trouble editing my profile, i signed up last night, and it told me i had to check my e-mail to log in, but i haven't got an email. Now when i get on, it lets me post (obviously) and says "welcome Tri-z_ek22" at the top, but i can edit my profile when i go to User Cp, or anything, so whats the deal?

Link to comment
Share on other sites

Hey i know this is a little late for this thread, but i'm new, Stoopidbot invited me here from Atvfan, just wanted to say hey cause i don't know anyone. But i'm having trouble editing my profile, i signed up last night, and it told me i had to check my e-mail to log in, but i haven't got an email. Now when i get on, it lets me post (obviously) and says "welcome Tri-z_ek22" at the top, but i can edit my profile when i go to User Cp, or anything, so whats the deal?

Hi Tri!

:cute:

Link to comment
Share on other sites

Hey i know this is a little late for this thread, but i'm new, Stoopidbot invited me here from Atvfan, just wanted to say hey cause i don't know anyone. But i'm having trouble editing my profile, i signed up last night, and it told me i had to check my e-mail to log in, but i haven't got an email. Now when i get on, it lets me post (obviously) and says "welcome Tri-z_ek22" at the top, but i can edit my profile when i go to User Cp, or anything, so whats the deal?
Welcome aboard , Tri-z ek22!:partyc:Hope you enjoy it here!
Link to comment
Share on other sites

Thanks to everyone, but i'm still having trouble with my user account thing, i can't do anything but post, so idk, when i get to the homepage here, nothing shows that i am logged in, but when i go to the forum, it says "hello tri-z" or whatever, i cannot do anything but post, and i've yet to get an email verification thing, i really need help here!!!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By gatorschevy
      I own a few older quads mix of kinds a couple of  Yamahas, a Honda, can-am  a Kawasaki, they are older quads but in good shape the question of the day is....... what's the best way to polish up the plastic?
       I have found that Dollar General mold remover is good to get the black stuff off the plastic works good, but was wondering how you polish up the plastics on yours.
    • By Superk
      Purchased a Ranger 150 for the kid and searching info online came across this site. Looking to update the fleet next year with a Turbo SXS.
      This is an upgrade from the Polaris Outlaw 50.
    • By Fish0rDie
      Was told there was some good information on this forum, so I'm here engaging in some good ole conversation haha. Bought a buggy aka shitcart for 100 dollars. Thing was a woods toy for the past owner. Used and abused until she went boom and was left in a field to die. All things considered that may be an exageration, but the top end of the warrior 350 that was on board was absolutely mangled. Piston and head assembly were totaled. Have a new jug, piston, and head assembly, but struggling to get the crankcase back together without the transmission binding. Can share pics that are on my phone if anyone is interested in seeing this shitty story unfold.
       
    • By Andrew Baker
      I need help with wiring on a 1998 (I think, 10th digit of the VIN was W) Bayou. I'm not getting spark, I'm pretty sure it is due to grounds being off because the harness is pretty hacked as far as the electric start and charging system goes. I'm needing a good wiring schematic. I found one online and there are a few things that don't add up on it so I'm skeptical that it is really for my year and model. Any help would be appreciated. Thanks. 
       
    • By kxpro8012345
      Hi All,
      I have a 1992 Suzuki King Quad 300. I got it in rough, picked apart condition on Facebook marketplace. The previous owner was not mechanically inclined and threw parts, and deleted parts to get this to "run". To give you an idea of what I am dealing with he put a non vacuum carb on with a separate fuel bladder mounted on the rear rack. I live in CT and things are a bit high here so I got the atv with a plow for $400. The atv came with (3) Carbs, 1 OEM, (2) petcocks 1 OEM. What I have done / found is the neutral safety switch was ate by mice (probably the original problem), fixed that, reinstalled (cleaned and put in a new needle and seat) OEM carb, the diaphragm is a little clapped out but still flexible, installed new Fuel pump, cleaned and reinstalled OEM petcock (non vacuum) has slight drip every now and again as I did not replace the tank side gasket when I installed and installed a brand new battery.  doing all that the quad fires and runs but briefly.  On the handle bar the choke paddle is broke off, I ordered that and looks like you need to remove the grip to install so haven't done yet and If i can get some direction on that as well, So that is "floating" in  the carb as I do not have the correct choke cable connector, I took the one off the Chinese carb and it somewhat holds it in place. The air box and system are gone and it has a stubby K&N cone filter on it currently.  So the way I start it is pop off the air filer, hold my hand over the carb to get a good enough vacuum to get to the bowl, then it will run for a few seconds. The tank is filled to the top, to help it out. Does anyone think I am missing anything before purchasing the entire air box system (If I can find it). This will be a yard machine for work and will not be taken out recreationally, cool little machine I would like to keep it, but unsure if I will spend the money on a airbox system as it for sure seems I am not pulling a good enough vacuum with out it. 
  • Similar Tagged Content

  • Gallery Images

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...