Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Sign in to follow this  
quadcrazy

2010 Kawasaki KVF 750 ( Gulfport / Biloxi)

Recommended Posts

(This Ad is from QUADCRAZY Classifeds, click "More" to find out how to contact the person who placed this ad.)

2010 kawasaki kvf 750 4x4i burgundy 158 miles 65 hours extras: 2 inch lift outlaw 28 inch mudlights on raceline wheels dinojet power comander power programmer muzzy performance exhaust warn winch comes with atv wramps 7,200 cash only s...

More...

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Topics

    • By Sha35297
      So, I got this 07' Polaris Outlaw 90 in the shop to rebuild top end and transmission. Replaced all bearings and gears in the transmission. Replaced cylinder and piston with brand new parts. Put the engine back on the frame and fired it up. Started great, but had a taping sound in the lower crank case. pulled the flywheel cover off and found the flywheel was wobbling and hitting the stator. I then replaced the stator and flywheel with brand new parts. Timing is all set on the timing marks now, but when I turn it over it kicks back when it fires and ends up stripping the starter idler gear. I've replaced the starter gear once already and now have to replace it again. Is it possible that the timing marks on the flywheel are off or maybe this flywheel is not for this exact model? Thinking of advancing the timing to try it, but don't want to keep going through idler gears.
    • By quadcrazy
      If you are a new member, why not introduce yourself? This community thrives and grows with you and all our current members! We all want this community to grow and encourage new member registrations. That being said please help out QuadCRAZY by inviting other atv'ers to the community.
      QUADCRAZY NEEDS YOU!
    • By ENG243
      Hello 
      I have a 1994 Kawi Bayou 400 which had been running well until it sat for about a month. I left the carb dry while it was park and the temp had dropped below 0C in this time. Pulled it out last night to go for a ride and it fired up just like it should but noticed when I started to head down the road I could hold it to the bar and it didn't seem to accelerate. Lower gears weren't as noticeable but 4th and 5th it just seemed to have no acceleration and half or full throttle  made no difference. if I tried to go into 5th gear with any throttle it would stall. I turned around and just poked home very slow and it seemed to stay running but this was between 15 and 20 km/h max. 
      I have taken the carb apart and it appears to be clean and nothing stood out on inspection to have dirt or ice. Is there something I should dig more into? 
      I have checked the plug and it appears to be sooty with easily rubbed off carbon. I plan to get a new plug today and test. 
      compression with the throttle wide open is 175 psi. 
      I have opened the drain plug in the exhaust thinking there could be a mouse in the exhaust or something but no difference. 
      I do find the engine is tickity compared to my 2000 Honda but I am not sure if this is just me looking for issues or if it has always been this way. 
      If anyone has any insight I would appreciate it.
      In the last 6 months I have done new oil and filter ( mystik synthetic) 
      new Peak RPM CDI 
      I have noticed the fan comes on more often with the new CDI, could this be a program thing?
       
      Mike
    • By Admin
      Looking for Kawasaki ATV VIN (Vehicle Identification Number) Number Decoders? Once you find your ATV VIN number off the tag on your Kawasaki ATV, you can go to all kinds of websites that have VIN Decoders available. The best ones are backed by the Kawasaki ATV manufacturer, however there are plenty of aftermarket Kawasaki ATV VIN Decoder websites on the web. This topic will stay pinned and if you find any to add, please do it with a reply. 
      The following Kawasaki ATV VIN Decoder websites are available where you can just enter your VIN number and it will shows you some of your ATV model details:
      CycleVin.com - Use Our Off-Road Vehicle Search to look up ATVs and more!
      KBB.com https://www.kbb.com/vehicle-history-report/ 
      CARFAX https://www.carfax.com
      autoDNA https://www.autodna.com
      VinAudit http://www.vinaudit.com/
      decodeTHIS https://www.decodethis.com
      VINCario https://vindecoder.eu/
      NICB Theft Check https://www.nicb.org/theft_and_fraud_awareness/vincheck 
    • By Hodadical
      I've recently acquired a 1995 Kawasaki Lakota KEF300A1 that seems to have a pretty slack chain. I've found an owners manual that talks about the procedure to tighten it to spec, but it mentions "inserting a bar provided in the tool kit into the axle housing and turning it upwards/downwards"... the problem is I don't have the tool kit that came originally with the ATV. Its hard to tell from the picture (and not ever having done this before), but it looks as though this "bar" may just be a pry bar/leverage tool. Is that so and I could just use a screwdriver or anything that fits into the hole? or is this a specialty tool and do you know where I can find one?
      Thanks
      -Rob
       
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...