Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

laxer35

Malfunction... Baja 90cc atv?

Recommended Posts

Hi, I have a baja 90cc atv. The battery went dead and the atv was sitting there for about a month. I got a new battery and now it will start up for like 2 seconds at full throttle without me touching anything after clicking the start button and then turn off. Its not moving because theres no clutch. Any tips on how to keep it running???????

Share this post


Link to post
Share on other sites


Hi, I have a baja 90cc atv. The battery went dead and the atv was sitting there for about a month. I got a new battery and now it will start up for like 2 seconds at full throttle without me touching anything after clicking the start button and then turn off. Its not moving because theres no clutch. Any tips on how to keep it running???????

Sounds to me like a fuel supply problem and or a carb problem. I'd start with checking the fuel supply flow from the tank and if thats good move on to the carb. However if the fuel is older than a month old I would remove the tank and clean the tank and then add new fuel along with a good fuel stabilizer. Fuel today goes bad pretty quick and can gum up a carb and cause the throttle needle to stick too. Hope This Helps, Whip

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Forum Topics

    • 2006 Can-Am Outlander Max 400 battery box fell apart

      The battery box on my machine kind of fell apart and I was wondering if this has happened to anyone else and what they did to rebuild the box.

      By johncb, in Can-Am BRP ATV Forum

        
      • 1 reply
      • 53 views
    • 2005 Polaris Trail Blazer 250 won't start

      Hi guys, trying to get a quad running again. It was running fine but the electric start did not work. My uncle was using it and the pull start snapped. So I replaced the pull start and electric starter motor. Now it just cranks and cranks but will not start. I have spark, I have fuel to the carb, I know this is a 2 stroke with a separate oil tank, what else should i check?

      By TheJester517, in Polaris ATV Forum

      • 7 replies
      • 232 views
    • Kazuma Falcon 150 First Successful Start

      Kazuma Falcon 150 First successful start after several years of employment. She was relieved to find that nothing was connected, everything was cut off, incomplete. No pipes or pipes, parts are missing $ 175!There was hardly a screw, the fasteners had plastic fasteners!  Kazuma Falcon 150.mp4

      By Knave, in Kazuma ATV Forum

        
      • 0 replies
      • 71 views
    • Kazuma 250 won't start

      I have a kazuma 250 utility atv, I believe it's a gator and this thing will not start for anything. I've got good spark and it will turn over but will not fire up. I can't find any kind of manual with useful info on this thing. Can any1 tell me what the stock car. Settings r on it so I can make sure they r rite.... I don't think tat s my problem but the more I can rule out the closer I can get 2 a solution. Thanks! 

      By Bobbi-Marie Giordano, in Kazuma ATV Forum

      • 5 replies
      • 65 views
    • 1999 Suzuki King Quad lt-F300F Hard to start

      Hello Just signed up, as I've had a recurring problem, and need some help. To start the bike I have to put the choke on all the way and 4 squeezes on the gas, Then as I push the start, I slow squeeze the throttle about half way for it to catch....If I miss it, then it will take 5 mins of slowly finding the sweetspot on the choke in unison with some throttle squeezes. Then I have to to hold the throttle to keep the bike going, using the choke will stall it out. after about 3 mins of holding the throttle, I then can let it go, and it idles fine, and runs fine. If it sits for a few hours it's only slightly hard to start, but a few days of sitting, and it's a lot more work. Had the bike serviced they couldn't figure it out. They swapped peticock, plug, new gas, all new lines, new throttle, and cable. Said the carb was fine, and clean. New air filter, said fuel pump was fine, no leaks around carb boots, new battery, new rectifier. Ran some sea foam through it....Runs Great.....Just such a pain to start... Thanks

      By RichUncleSkeleton, in Suzuki ATV Forum

        
      • 4 replies
      • 1,896 views
  • Similar Tagged Content

  • Recently Browsing   0 members

    No registered users viewing this page.


×