Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

bigmike4

blinking fi light

Recommended Posts

i have a 2007 kingquad 700 the fi indicator light is flashing on the led display it turns over fine but wont start. i took the injector out it doesnt appear to be spraying gas. i really hate to ask for help on this but im no mechanic . i bought this quad for my sons and was took to cleaners have had nothing but problems . so any help would be greatly appreciated thanks

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Tagged Content

    • By Billie
      :confused:need a repair manual or help in what to look for thank you Bill
      for you muddober to make clear to you the neutral light and the gear light
      do not light up win shifting fuses are good Iuse my CAt for hunting im dissable the atv is my leag s thank you
    • By stevebula
      Hello,
      i have a baja 250u wilderness
      and the neutral light wont come on
      hence i cant start it unless i pull start it
      any input would be great
      thanks
      the quad is in neutral and rolls just no light and no start
      thanks again
    • By bodatiouskid
      Help!
      Have an 02 Kawasaki Prairie 650.I replaced the belt & when I put everything back together the 2wd-4wd lights would flash back & forth.
      I read how to reset light,but my ATV doesnt have the black & gray wire connectors where they are supposed to be.
      Anyone know how to reset lights on this model?
    • By toonces
      Really don't like the idea of wearing a helmet but for safety's sake I cant justify flying down a dirt road at 45 without wearing one, so I'm wondering what's a good helmet to get for someone who doesn't want a helmet on at all. Light weight would be a priority as well as open face.
    • By bobmn1967
      Hi i have a 2012 kymco maxxer 375 . I noticed the temp light on lower left hand corner of the lcd screen . The light is on before i start the ayv on cold start ups and does go off .. What causes this and does anyone know a fix for it thanks
  • Similar Topics

    • By Stephanie Webb
      I have a 2000 500 quadmaster lta an just rebuild the gear box an my high gear is like nuetral will not move but all other gears move nothing looks broke just need some help cant figure out what gear that would be or if it could be the shifter fork 
    • By Susan Makowski-DeGraw
      My quad runs,  it starts up runs for about 10 minutes and then it dies if you let it sit for 10 minutes it’ll start back up ride for another 10 minutes and then die again, trying to figure out why it keeps stalling
       
       
    • By NoahJakavi
      Hello i have a linhai 300 of the 2004+- era. I had a cluch problem so we changed it. After changing it has a hard time to start going. When you pop it into gear and press the gas it barely drives but when it starts going about 20km/h it start driving well the acceleration is normal and everything do you have any idea of what could be the problem
    • By Budman
      After purchasing a lightly used 2018 570SP (300 miles on it) I noticed that the display was flashing on and off. I remember reading awhile back that this was a common problem on the 18 model. I can't remember what the fix is. It also turns over slow even though the battery is charged. Anybody know what the fix is on this issue?
      Thanks
      Budman
    • By VikingTrad3r
      picked up my third timberwolf 250 for my daughters.  these are great light weight little quads.
       
      have a strange one for you.  the quad will NOT start in neutral.  it will start in first. 
      if i lift up on the gear selector just enough to hear the little click (its not loud, sounds like a contact clicking, perhaps the neutral safety switch?) the light will go out, but it won't yet be in first either.  that is how i have shown my daughter to start it and she can.
       
      id like to carry out whatever repair is needed.  i have the pdf of the shop manual but it doesn't really have a flow through diagram.
       
      any help appreciated!  thank you.
      i need to add something.  it feels like i can switch into another gear BELOW neutral.  
      so if i switch to neutral, i can keep pushing the gear selector, and it has another click below the neutral.  the light stays on, and when i pull up into first it kind of feels like it has two positions it moves through to arrive at first.
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...