Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

toonces

What's a good light helmet?

Recommended Posts

Really don't like the idea of wearing a helmet but for safety's sake I cant justify flying down a dirt road at 45 without wearing one, so I'm wondering what's a good helmet to get for someone who doesn't want a helmet on at all. Light weight would be a priority as well as open face.

Share this post


Link to post
Share on other sites


I ride with all O'Neal helmets. They are comfortable, light weight, and take a lot of abuse.  I ride on tight trails, with lots of tree branches hitting me, and have the occasional gravity check and have not had any problems with them.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Forum Topics

    • Bayou 220 won't start -- neutral light in every gear

      The story goes, my daughter "did something" to the ATV and now it won't start. I suppose these things aren't kid proof. All I know is that the Neutral light stays lit no matter what gear, and subsequently the starter won't turn. I briefly Googled but only came across symptoms of the Neutral light never lighting up. I have downloaded the service manual from this site (thank you) but don't quite know where to attack it first. Thanks for reading.

      By deckeda, in Kawasaki ATV Forum

      • 3 replies
      • 759 views
    • Neutral safety switch

      I’m looking for any member that may be familiar with the neutral safety switch on this bike.    I picked up a bayou 220 that I found sitting in a shed. Nice looking bike the guy said it would not start one day and put it away and never touched it again.   So it turns out the neutral safety switch is bad.  I jumped it out and the bike fired up and runs good.   I’m more then capable of the work in changing it but this thing is buried pretty good. I’m curious if anyone has done the switch replacement before?  I attached some pics to see. picture 1 is the side view you can see the green and red wires going into the cover.  Pic 2 shows looking down on the drive shaft coming out of that cover.  That is not a simple cover you just pull off.  Im wondering how deep and how much shit has to come off like the drive shaft etc for this switch  to be replaced.  So if any of the QC members have done this switch I’m looking for any input with regard to changing it.   Thanks. 

      By Frank Angerano, in General ATV Discussion

      • 14 replies
      • 151 views
    • 2010 Brute 750 belt light will not reset

      I assume engine is in limp mode because light is on. any suggestions?

      By Justin Johnson, in General Talk - Anything Goes!

      • 0 replies
      • 86 views
    • Linhai Bighorn 260cc doesn't move

      My linhai 260cc runs, it goes into gear but it doesn't move.  What are some suggestions as to what could be wrong. 

      By Ashley Mctheny, in Other ATV Brands Forum

        
      • 5 replies
      • 543 views
    • 2004 Polaris Magnum 330 4x4 - Overheat Light & AWD engage

      Hey Guys,  I think I've got a bad ECU, but wanted to know if anyone has had similar problem before forking over the $200 for a new one. Bought this rig from a buddy last winter.  Buddy let me know on issue before purchasing. Occasionally the overhead light would comes on...even in winter rides.

      I have followed fan trouble shooting, it powers up when direct connected to 12 V power supply and draws correct amps per manual. Just recently, the light has come on when unit is cold and first started up.  Or sometimes if not on right away, overheat light will come on right after starting within a minute or two into ride. When fan comes on seems like it cycles on and off more than it should... Oil level is good and hoses seems fine....one hose will be hotter than the other when checking, so that tells me the oil is flowing through the cooler. Any ideas what temps should be from oil out and return?  I could check with infared heat gun... And most recently, now I just had an issue where the light for the AWD does not come on right away now after switching on.  Comes on and off intermittent when switch engaged. What do you guys think...is my ECU on the fritz? Thanks ahead guys...any other ideas to trouble shoot would be appreciated. Toneloc.    

      By Toneloc, in Polaris ATV Forum

      • 3 replies
      • 202 views
  • Similar Tagged Content

  • Recently Browsing   0 members

    No registered users viewing this page.


×