Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

DrPinstripe

Carb part for Linhai Bighorn 300

Recommended Posts



Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Forum Topics

    • By abe
      can someone tell where  solenoid  located in kawasaki 1994. i been looking all over can find it.
      thanks
    • By ron755
      I have a 94 Yamaha Timberwolf 250 4x4. I have no fire to the ignition switch, no nutral light, head lights, or tail light I can jump across the selinoid and start it. I put on a new solinoid. The neutral light comes on,while running, but dims when you give it throttle.
      Would this be a relay, not letting fire go to the key switch? If so, could someone post diagram from a manual, on how to test the relays?
      Thanks for any help
      Ron
    • By Mario760
      Need help my friend brought me his raptor to fix because it wouldn't start so I cleaned the carb and all was well till last night when I tried to start it again and there's no power and by power I mean lights don't turn on also won't turn over neutral light won't turn on either I checked the fuse and that's good and everything is plugged in battery is charged and I need help I cant find the cdi wiring diagram anywhere to test each cable so any help will be appreciated thank you!!!
    • By Tony Amato
      I recently bought a 2008 Polaris 90cc outlaw for my daughter it only needed a few things like a carburetor and a transmission shaft which I fixed with ease. The headlights on this vehicle are dim so I bought a aftermarket set of headlights also a  small winch does anyone know if the stator puts out enough voltage to run these extra accessories do they sell a stator that puts out higher amps? I would appreciate any help that you guys should give me
    • By Squirrel
      Thought I'd throw this one in the club section to help raise the lack of activity here. I'm fixing up a '00 Bayou 220 that I picked up last weekend; needs the carb rebuilt, at least that's all I was hoping it needed. Anyways, decided to check the battery, starter, spark, all that jazz so I was good to go when I got the carb fixed.. and that's when I found an intermittent short in the start switch as well as the headlight switch. So I removed the switch housing from the handlebar to find this:

      I dismantled the entire assembly, blew it all out with compressed air, cleaned everything including the corroded contacts, and then reassembled it all making sure to put dielectric grease on all the exposed electrical. It looks 1000x better than before and everything works as it should (though I think I installed the kill switch backwards lol). 
      My question is this: Is that good enough? As a former auto mechanic, I'd always seal any external electronics to prevent dirt, moisture, etc from getting in. However, the design of the housing doesn't really make this possible. I'm not trying to make this thing 100% submersible, but with the switch being old/original I'd like to know it won't fail on me if I get caught in a downpour or something.
  • Similar Tagged Content

    • By Jeff Wharton
      I have a 2000 Arctic Cat 300 4 wheeler. I have been having some carburetor issues. So i bought a new carb. Now I'm having these issues. The unit will start and idle fine, when i go to accelerate it wants to cut off. So i checked to make sure it was getting gas and the fuel filter will be full of gas and then once the carb opens the filter drains down and will not refill quick enough to run. So i checked to make sure gas was flowing to the filter and it is flowing fine through the line. I remove the filter and run the gas line directly to the carb and the engine idle fine and then it will run good as i ride it for about 10 minutes then it will start with the same issues again i cannot accelerate enough to move the 4 wheeler. Every time i accelerate the unit will cut off. What is wrong with this thing. My 400 Arctic Cat is doing the same thing except it will backfire, I'm lost i have tried everything i know to do, what am i missing here. Thanks for your help
    • By Maurais
      I’m looking for new replacement shocks (front & rear.) on my 1997 Kawasaki Bayou 300 2x4. New OEM shocks are upwards of $400. I haven’t pulled the rims off to check the eyelet to eyelet length but I’m hoping an expert on this site does know( I called Kawasaki direct yesterday and they were of know help.) Any technical help would be appreciated. TY fellow members. Vic
    • By scottj11
      Hello, how are you'ns doing? I'm in the process of tearing my Kawasaki Bayou down to fix a rattling noise and an oil leak. I'll probably be asking questions about this project. My step-son has an Arctic Cat 300, he was riding yesterday and when he turned it off it was running fine, but it won't do anything. The lights come on but it won't turn over or anything. Does anyone have any ideas on what might be wrong? TIA
  • Recently Browsing   0 members

    No registered users viewing this page.


×