Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

precision17

baja atv 50cc clutch concern

Recommended Posts

my son has a 50cc Baja atv automatic trans that at time (right now) jerks then dies, once he trys to start it the starter causes the quad to lunge forward like the clutch is not releasing. when this happens, you cannot push the quad backwards either even with the engine off. if you raise the rear on a block it will start but the rear wheels will spin even at idle, if you pull the quad off the block the load of the machine will instantly kill the engine. im guessing its a stuck clutch issue however I cannot find any info anywhere. im an ase master auto tech so I am pretty mechanical just need a point in the right direction. any help would be greatly appreciated. thank you in advance!

Dana

Share this post


Link to post
Share on other sites


Get into the clutchs and see whats wrong.

Find a site with a fiche so you know how it is supposed to be.

Being a mechanic, I feel you will be fine. :)

Share this post


Link to post
Share on other sites

Hmmm...makes sence.. Thats what you recommend to your auto customers right..

~no reason to change your oil , itll come apart and well change it then~...j/k. LMAO :D

Share this post


Link to post
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Forum Topics

    • Yamaha Terrapro dies when going into high gear

      Need help solving an issue.  I recently got this.  Its missing the pto system.  It only drives in low gear, when switching into high gear,  it shuts off.  Please help. 

      By A B, in Yamaha ATV Forum

      • 1 reply
      • 39 views
    • 2005 Polaris Trail Blazer 250 won't start

      Hi guys, trying to get a quad running again. It was running fine but the electric start did not work. My uncle was using it and the pull start snapped. So I replaced the pull start and electric starter motor. Now it just cranks and cranks but will not start. I have spark, I have fuel to the carb, I know this is a 2 stroke with a separate oil tank, what else should i check?

      By TheJester517, in Polaris ATV Forum

      • 7 replies
      • 231 views
    • 97 Polaris sportsman 500 runs about 10 sec then dies

      Hello, Everyone first time here, I appreciate this opportunity, I have a 97 polaris sportsman 500 that I just acquired, been sitting awhile ,would not turn over with a new battery, replaced the starter, got it to turn over, but no fire, replaced the coil, cdi box, new spark plug, spark plug wire and boot, still no fire, So I changed out the stator, boom I have Fire, Carburetor was in bad shape ,so I installed a new carburetor, a new fuel pump and filter and all new hoses, and before I tried to start it I cleaned the fuel tank, well here we go, It started right up idled like a brand new one, Idled for about 10 seconds and died, fired right back up idled great and revved up great, but in 10 seconds it died, fired right back up, this time I held the throttle about half throttle, and it kept running, but when I let off it died, so I then adjusted the throttle cable from all the way tight to all the way loose, and vise versa, still the same thing, Please somebody help, cause I'm bout to give it the HAMMER TEST.   

      By Danny Gardner, in Polaris ATV Forum

      • 17 replies
      • 173 views
    • Kazuma Falcon 150 First Successful Start

      Kazuma Falcon 150 First successful start after several years of employment. She was relieved to find that nothing was connected, everything was cut off, incomplete. No pipes or pipes, parts are missing $ 175!There was hardly a screw, the fasteners had plastic fasteners!  Kazuma Falcon 150.mp4

      By Knave, in Kazuma ATV Forum

        
      • 0 replies
      • 69 views
    • Kazuma 250 won't start

      I have a kazuma 250 utility atv, I believe it's a gator and this thing will not start for anything. I've got good spark and it will turn over but will not fire up. I can't find any kind of manual with useful info on this thing. Can any1 tell me what the stock car. Settings r on it so I can make sure they r rite.... I don't think tat s my problem but the more I can rule out the closer I can get 2 a solution. Thanks! 

      By Bobbi-Marie Giordano, in Kazuma ATV Forum

      • 5 replies
      • 65 views
  • Similar Tagged Content

  • Recently Browsing   0 members

    No registered users viewing this page.


×