Osiris

250 four-trax 1985

Recommended Posts

Wheeler will start and run but when throttle is pushed it dies. I checked the pepcock for blockage and found none? Carb was just cleaned as well. Only way bike will move if full choke and minimal throttle. What am I missing? Bike ran good all day then went to crap. I did limp it home but now I'm confused???

Share this post


Link to post
Share on other sites
  •  Like what you are reading? Please help us by sharing this content.


It  is starving  for  fuel  when  you  open  the  throttle . . Pull  the  carb  and  clean  it  again. Check  all  the  jets  for  blockages and  blow  out  the  passages.  Make  sure  the  float  level  is correct  so the float  bowl  fills  to the  correct  level. When  cleaning  the  jets ,   make  sure  to  look  for  some  very  small  holes in the  main  jet  tube  that  might  have  been  missed in the  last  cleaning .. Running  good  all  day  and then  going to  crap  tells  me  the  carb  most  likely  picked  up  some  small  dirt that  was  missed in the first  cleaning  and  became  mobile  to  pug  a   jet .  It  often  happens  in  machines  that  have  sat  for  a  long time  and  have sediment   missed in the  bottom  of the  float  bowl,  or  maybe  got  by  the screen    on the  fuel  valve .

Share this post


Link to post
Share on other sites
  •  Like what you are reading? Please help us by sharing this content.

Plugged jet thanks now it leaks fuel from the bottom...I am getting good at taking it apart. 

Share this post


Link to post
Share on other sites
  •  Like what you are reading? Please help us by sharing this content.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  •  Like what you are reading? Please help us by sharing this content.