• Sign Up, it's FREE!

    Welcome to QUADCRAZY! Use the main menu and search bar to navigate our site. It's always FREE to join our ATV Community and post in our forums, create your own ATV club, share your photos and videos, download manuals, and more. It's easy to get started and you can login with some of these popular social networks.

Recommended Posts



Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  •  Like what you are reading? Please help us by sharing this content.
  • Similar Content

    • By Aidan
      Hi, 2 years ago I got a 2002 Kawasaki Lakota Sport 300 for $50. Yes, I know, vary cheap, and it came with issues. The issues were, a leaky oil cap, a carburetor that fails when going up or down hill, and a flat tire that will not fill up. It also has a broken exhaust, as in broken, the tip of the exhaust is no longer there, so it is loud, but works fine. I have the oil cap, and a carb repair kit, but I need help finding a right rear tire for it, also I need ether a entirely new exhaust for it or somehow repair it, I dont have the old piece to the exhaust. Feel free to ask me questions. I will put a pic of what the exhaust is supposed to look like.


    • By buzzar56
      I am looking for a free repair manual for a 2003 Polaris sportsman 500 ho atv. all the posts on here lead me noplace
      thanks fred.
    • By pickytar
      I have a Chinese Hybird 250 or that's what I was told it was. I found 17 numbers on the frame. Will these numbers tell me exactly what it is that I have? (I know that its a 2006 from a plate on the front)
    • By txlora84
      I have a 110cc atv not sure of a brand its a Chinese model. I put on a new harness with cdi solenoid and all those. I have put a new starter on, and carburetor. I bypassed the start button cause it was just making the solenoid click. with the new button switch the atv will crank but not start. I tried to jump the solenoid and it did nothing. I am stumped. also I noticed gas leaking from the carburetor and when I took the filter off there was gas in it. I cleaned the carburetor and nothing was stuck or clogged. can someone help me out.