Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

gregj49

2005 Arctic Cat 500 Starter Click

Recommended Posts

Have a 2005 arctic cat 500 when you press the starter button all it will do is click I have replaced the starter and solenoid and replaced the battery. Don't know what else I can do!!

 

Share this post


Link to post
Share on other sites


Hello, is it clicking like a relay or the solenoid is clicking?

I moved your topic to the Arctic Cat forum and added issue to your topic title.

Share this post


Link to post
Share on other sites

Is that starter tight and making good connections? I hate to say it but if its new and clicking...sounds like you are getting power to it and the starter is just not engaging. I would probably tap on the starter with a small hammer and see if it starts, may have a low spot in that new starter. Try also jumping the starter to see if it engages.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By NathanFisk
      I have an 2003 Kodiak 400 Automatic and for some reason the starter not engaging I’ve replaced it still nothing it spins freely but not engaging. It was running fine the day before I am no expert so can someone please help me
    • By AKMichael
      Hello All,
      I have a 1999 Yamaha Big Bear 350 4x4 trying to get fixed up so my grandson can go out in the woods with me.
      We have owned it over 10 years.  It got harder to start, until it finally would not.  Replaced the carb.  Right afterwards, it started and ran nicely, but after turning it off, would not restart.  Tonight I used starting fluid and ran, then died.  Adjusted the idle up a little, used more starting fluid and ran great.  It idled about 15 minutes.  Turned it off, and restarted.  Ran it around the yard about 5 minutes.  Turned it off, and would not restart.
      Any ideas or suggestions would be greatly appreciated!
      Thank you. 
    • By Sha35297
      Customer brought in this bike for no response when put in gear. After getting into the transmission I found the main shaft for the clutch had been stripped where the gears mesh up and also the shaft for the gears had been broken in half. I replaced all broken parts and reassembled the transmission. Now it makes a knocking noise in low gear and in reverse. When in neutral it tries to roll reverse while making the same knocking noise. I’ve disassembled and reassembled it several times with the same result. Any ideas??
    • By Ajmboy
      With this cold snap, I noticed yesterday that the battery on my grizzly was a little weak. even clicked a few times before I got it to start. I'm thinking of picking up a batter tender/ trickle charger so was wondering what people use to keep their ATV battery charged up. I was looking at these on amazon. They both have good reviews.

       
      or this one

       
      Kind of like this one because if the accessory plug

    • By Josh Cornelius
      just rebuilt the carbs because it sat up for a few years and wouldn't run at all. now it idles, but only with choke. you can give it just a little throttle but not much before it tries to die, take choke off, it dies (warm or cold temp). air fuel mixture doesn't really effect it at all and it'll still idle with mixture screws all the way in. any help/ideas would be greatly appreciated!
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...