Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Chris Warren

2008 polaris outlaw 90 cc

Recommended Posts

Hey guys new to this forum. I have a 2008 Polaris Outlaw 90 cc and I just got it running after it was sitting for a few years. It runs well but I have no running front lights or tail light. 

Share this post


Link to post
Share on other sites


Welcome to QUADCRAZY! Have you checked all your fuses? I would start tracing wires from the light switch and testing for power.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By donerightautomotive84
      Ok so 2000 sportsman new.caltric carb new fuel pump new jug and piston new cdi and coil finally get to start it and itll idep for 5 to 10 seconds and die what am i missing people any help id love ya forever lol
      Sent from my LM-Q720 using Tapatalk
    • By Marc DiTomasso
      The Polaris phoenix 200 will not go forward only in reverse, it just happened out of the blue, I’m wondering if someone could help me figure out what it is
    • By Zad
      1994 Polaris 300 2x4 project won’t start. Seems like we have spark and have tried straight starting fluid in cylinder and still not getting a fire.   Kind of has me stymied 
    • By Chase Cook
      Have a 2001 polaris sportsman 500 4x4 atv and when I put coolant in the radiator it starts leaking from the exhaust. The valves are sealed but it stopped making compression. Do I need to just replace the head? I just rebuilt the hole top end and this is the only thing +valves that I have not replaced and was wondering if that is why it's not starting up. Need answers please.
    • By JacobSlabach
      Hey so i sold my 04 rubicon and wanted something new so i went to NC and bought a '13 scrambler 850XP LE EPS.  love it the only issues with it when i bought it were a leak in the front tire and the mice had chewed through one of the spark plug wires.  currently have a substitute hooking the chewed end to the ignition coil so itll run on both cylinders however im having an issue finding a replacement coil wire for it and was wondering if yall had any advice.  i need the longer of the two coil wires and i can only find the shorter one online.  will throw up some pics of it when i can
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...