Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Shonko72

2003 Suzuki LT-Z 400 Need Left Engine Case

Recommended Posts

I am looking for a 2003 LT-Z 400 left engine case anybody have one or where I could find one PLEASE Help

Share this post


Link to post
Share on other sites


Topic moved to Suzuki forum and added full ATV info and what you are looking for into the topic title.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Ryan Foster
      I am trying to find a used OEM cylinder for the above mentioned quad. I was told the current cylinder came from Amazon so I suspect its aftermarket china (made from recycled coat hangers and shopping carts.) Anyway, was looking at the parts list and they have 2 cylinders listed..
      11210-19B82-0F0
      MODEL X/Y
      and..
      11210-19B90-0F0
      MODEL K1/K2

      My engine case is stamped K403 230829 Trying to figure out what model I have. I see I have a K in there but....
      I don't know what the differences are between the cylinders (the first one cost more). Anybody know how to decipher this?
      I only have the engine, I don't have the frame to get the actual VIN.  

      Also, are there any marks on an OEM cylinder to differentiate it from aftermarket?
       
    • By David Miller
      Does anyone know how to access the check engine codes on a 2018 450 sportsman. Just changed battery and spark plug . It runs fine but the light is on and I need this to plow snow and need it reliable. Any ideas . Thanks
    • By K L Buck Naff
      Trying to replace the carburetor on my 2003 Bear Tracker 250. Two brand new carbs in a row from different suppliers.   Both leak fuel out over flow and intake as soon as I turn the gas on. Any ideas. Am I doing something wrong?
    • By Amazon Ads
      Where do you buy your ATV parts? Did you know that Amazon has ATV parts in stock for immediate delivery? You'll find all the best ATV parts and for great prices! Check out all the ATV parts available with free 2 day shipping now...
    • By dany desbiens
      Hello i have a Polaris 2003 sportsman 600 Polaris Sportsman OEM Gauge Speedo Speedometer Display Dash Cluster 3280425 the speedo is not working no 4*4 i can find nothing can i put a speedo 2004Speedometer Gauge Speedo
      3280431 04-08 Sportsman if it will work
  • Similar Tagged Content

    • By Steve Simpson
      Any suggestions on where to buy new parts want new jug piston rings would like to go wiesco big bore 
    • By jamesbailey8809
      I have a ltz400 2012 model that will not start only turns over I was riding in 2nd gear and it was lacking power I hit the gas and it just shut off on me would not start any more before it shut off it started ticking does anybody know what is going on when I try to start it now it only turns over like it has little compression when you give it gas the compression goes away and only the starter turns
    • By brstone34
      Anyone have a manual for a 2003 LTZ400? I cant seem to upload from the manual board page.
    • By azmatson
      Hi I don’t know much about quads this is my first one have a 2006 Suzuki ltz400 when I got it they told me that is has a 440 bore kit and a hot cam, but the throttle has to pushed and pumped to get it started, so I cleaned the carb and it is running good now but the throttle still has to be pushed and pumped to get it started the choke axe like it does not work and it bogs down in reverse. Does anyone have any advice?
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...