Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Bob Heckendorf

2015 Arctic Cat TRV500 getting water in crankcase!!

Recommended Posts

I ride with several friends that have Polaris ATVs...I have a 2015 Arctic Cat TRV500. We all go through the same fairly deep puddles on the trail, and my Arctic Cat always gets "wet" where I'm finding that water is getting into my engine. I have to change oil several times to get rid of the "milky" look, and the machine seems to run fine again. Where is the water coming in from? Is there an air breather maybe loose or misplaced? I'm new to this 4-wheeling so could use all the help. Is Arctic Cat just prone to not being able to handle deep puddles??

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By FlyingJBIRD
      I've bought a used 2007 Polaris Phoenix 200... it's in pretty good shape... but after it starts, warms up, a few minutes of my son riding around yard it will die... it refuses to start back until the next day, then same thing again... I've seen this is a problem but haven't found any real answers... my son is driving me crazy to get him back riding... any help is greatly appreciated...
    • By fish4ever06
      My daughter 06 Pheonix ll onl run forabout 10 minutes befoe it sarts sputtering and finally dies, have cleaned the carb and jets 3 times and added an inline fuel filter as well as new gas. Any other ideas would be appreciated?
    • By Eddie Lambert
      So I picked up a Cannibal that has been sitting for many years. I wonder if anyone can tell me where that vacuum port is on the engine. I’ve found the one to the air box, pressure regulator, and ecu but can’t seem to locate the one on the engine. Thanks in advance for any help. 

    • By Ashton Crawford
      Hello everyone, i have 2000 Polaris Trail Blazer 300 I’ve been stumped on for weeks. I’m having a lot of issues starting the quad. I cleaned the carb spotless because I thought it was a carb issue and bought a new fuel line because it wasn’t getting fuel. The carb gets fuel perfectly fine now but it won’t start. The spark plug I a little worn out but it’s good enough for just one start. The only time it does “start” is when I spray starter fluid into the carb. But it never stays on. It’ll start for a bout a second then just die out immediately even if you’re giving it some throttle and the choke is on. I have no clue what I should do. If you need more information, have questions, or have any slight idea what the issue would be and how I could resolve it. Please reply ASAP. Thank you.
    • By 06kfx440
      I have permission to ride 60+ acres that vary in technical aspects. Let's make something happen. We have off street parking and it's a ton of fun.
       
      Sent from my SM-N920V using Tapatalk
       
       
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...