Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Popeye

08 Kazuma Jaguar 500

Recommended Posts

Needing to know what goes between exhaust port pipe and fuel pump connection. Just bought 4wheeler and rubber hose keeps burning holes and gets fuel pump extremely hot. Is there something that restricts the heat to guel pump?

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Dra O
      posted a while back - it was running at one point - I have all the plastic shroud off - it's down to frame and engine now
      -fuel pump: when line from petcock is attached, no fuel comes out other side to carb; the line to the carb is open (can blow through it); I thought when I cranked engine that the pump would spit out fuel on other side but it does not; I removed fuel pump and opened it up - diaphragm looks good - but internal areas had lotsa calcification build up - I cleaned this out and dried it good - the clear plastic pieces (?diaphragms) aren't broken - the spring w/ steel ball on end moves freely; am putting it back on tomorrow; but can anyone answer about the pump? isn't it supposed to pump fuel through it... to other side... to carb? puzzling
      -along with fuel pump: I replaced petcock 3 weeks ago (gas tank had rusty fuel in bottom - cleaned it out prior to new petcock); when I turn petcock arrow NOT to on or reserve, fuel comes out of line; when I turn it to on or reserve, fuel doesn't come out; puzzling
      -I don't know what's on back of fuel pump - it's a valve that has a hose coming out of it - looks like it goes to engine/carb - I haven't traced this out yet - what is it?
      -can squirt gas on air filter and engine will run for 2-3 seconds then stop - fuel in top of carb (under diaphragm) does same
      -it likely needs carb rebuild - will get to this - but something isn't allowing fuel to get from fuel pump to carb
      -I THINK it has a mikuni model x carb - diaphragm is ID 26mm  OD 68mm - hard to find inexpensive diaphragm, I guess because it's a model x
      -last thing - I replaced solenoid due to old one clicking; I HAVE to be charging the battery or it won't start/turn over - battery just goes dead; but if charging, it'll turn over nicely; i'm guessing it's a bad battery
      -any help appreciated - I've never owned an ATV before - inherited this beast from grandparent in-law
    • By Chase Cook
      Hi I just got an Polaris sportsman 500 4x4 ATV the other day. I got it real cheap but I started to go into it because it didn't have compression so I bought a new piston and ring kit for it and installed it, but now when I try to start it all it does is shoot fire out the exhaust or the intake of the carburetor. And a timing is top dead center.;I think I can't really tell another way if it is or not. when I put it together I made sure to piston was on top and the cam lobes where facing down where are the cam sprocket is facing up. It has gas and spark. It did start a couple minutes ago but it didn't stay running and now it won't start. Do you think the valve need to be adjusted more to close better?I'm fixing to try that out and if that don't work what is the problem? Also I made sure everything was together good and right and change the oil and changed out the radiator fluid.
    • By Brian Sosebee

      I just rebuilt my 03 sportsman 400. Put everything back together added oil per the manual. Pinched off the oil tank vent line 2" away ran for 45 seconds then cut it off. Check oil level and it was still way high so I wasn't confident that it primed so I did it again. Checked again and it's the same. Remove the oil filter and it is dry. I did the procedure again and the same results.

      I'm worried to keep trying this as the only oil in the engine is what I used to lubricate the parts when reassembling the piston. The crankcase was drained as well.
      I Removed the oil tank and checked all the lines for obstructions and the screen filter and the vent hose and everything is clear. I even pulled a small vacuum on the oil tank while it was pulled off to make sure there were no leaks. The dipstick cap was on tight so I'm not sure why this thing is not priming.

      Anyone have any suggestions. I thought about pre-priming the oil lines from the oil tank to the crankcase to hopefully help the system prime. I'd like to be able to add some oil to the crankcase to so I wouldn't feel so bad about running the engine for another 60 seconds without oil. I dropped just a little bit of oil in the spark plug hole to help condition the sleeve right now.

      What do I do? Anyone had or heard of an oil pump failure on these. Btw oil pump is working fine before I did the top-end rebuild and the oil pump was not touched.

      Please help!!! Thanks all for any and all help.
    • By ken hathaway
      Tried to start my 850HL the other and had no spark. Changed the plugs, but while checking for spark noticed not getting fuel either. So no spark and no fuel. ECU? Anyone else have anything like this?
    • By Nick Brooks
      Working on a 2002 Quest 500 and the grommets in the tank are rock hard and leak.  Any tips on replacing without having to pull the tank, hands are too big to get to the bottom gromment which is the worst one.
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...