Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Recommended Posts

Hi Guys,

I have a small Sled Dog business and I train up to 14 Huskies pulling a Yamaha Grizzly 550, that is quite a lot of Horse (Dog) power. Sometimes in order to make the ride smoother for Dogs and us we ride in Neutral but on a few occasions I have noticed that the right hand (front) brake seems to loose pressure and does not brake at all. Is there a particular reason for this ? Is it a fault or is it something to do with us riding in neutral, I only use the ATV in this way a few months a year before the snow comes but I am sure I recall the same thing happening last season.

Any ideas would be greatly appreciated because I am a far way from being a mechanic.....

Have a super day and thank you all.

Craig

Lapland

Craig overnight Jakala.jpg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Tagged Content

  • Similar Topics

    • By VikingTrad3r
      picked up my third timberwolf 250 for my daughters.  these are great light weight little quads.
       
      have a strange one for you.  the quad will NOT start in neutral.  it will start in first. 
      if i lift up on the gear selector just enough to hear the little click (its not loud, sounds like a contact clicking, perhaps the neutral safety switch?) the light will go out, but it won't yet be in first either.  that is how i have shown my daughter to start it and she can.
       
      id like to carry out whatever repair is needed.  i have the pdf of the shop manual but it doesn't really have a flow through diagram.
       
      any help appreciated!  thank you.
      i need to add something.  it feels like i can switch into another gear BELOW neutral.  
      so if i switch to neutral, i can keep pushing the gear selector, and it has another click below the neutral.  the light stays on, and when i pull up into first it kind of feels like it has two positions it moves through to arrive at first.
    • By Blenderite
      Hello guys! New to the forum, and fairly new to ATVs. I've driven them, but never owned one. Now I do own one. Just picked it up today. It's a 1999 Yamaha Big Bear 350. It's been through some stuff. The guy I got it from told me the previous owner removed the front diff because he didn't want to replace the half shaft. So it's 2wd, even though it's supposed to be 4x4. Lovely. I can deal with that for now.
       
      More importantly, I need to get it running. The carb needs to be rebuilt. The guy I got it from said he sprayed it all out and it still didn't work. I'm concerned he might have damaged it or not put all the parts back. I was looking at a replacement carb, and the OEM parts is $600. I'd rather not spend $600 if there are any other options. I have seen carbs on Amazon and eBay that are in the $40 - $100 range that say they fit. Anyone have experience with these? I'm going to get a rebuild kit for the current carb just to make sure that won't fix it.
       
      Thats the first thing with it. Secondly, it was completely rewired. I need to find a original wiring diagram so I can put it back how it was, with a key and all. Currently it's wired with just a rocker switch. Any sources for a service manual that would include wiring diagrams?
       
      Thirdly, is the Big Bear 350 a good atv? I picked it up for $700. It does start and run when you spray starting fluid into the air intake, so I am not concerned about the engine being bad. I plan to use it for the farm, running around and carrying things with it like minerals and feed and such. Not really for mudding and things like that. How good is the 99 350?
       
      I am certain I will have more questions as I examine it more, but that's all for now. Thanks in advance for the assistance!
       
      -Blenderite
    • By jolio
      Just got a '98 Yamaha big bear 4x4 in working condition (so far). Looking forward for some good information on this site about how to keep it alive.
    • By Asen_77
      Hi All,
      My name is Asen and I am from Eastern Europe, Bulgaria. Riding a Yamaha Raptor 700R and this is my first Quad wanted for a vey long time :)

       
    • By Spike976
      So I dug my warrior out of storage replaced the carburetor with one off Amazon & it was running great. Last week it didn't want to start it would crank & I could smell gas but nothing. I replaced the starter,stator,solenoid,spark plug & coil & resistor but still not starting. Checked the stator and its at 30 ohms tried using starter fluid but nothing. I am completely lost and could use some help thank you
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...